aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGilles Chehade <gilles@poolp.org>2017-01-08 19:35:11 +0100
committerGitHub <noreply@github.com>2017-01-08 19:35:11 +0100
commit4e1b8db55e04d3b03d732e8163523bfc488cc4e0 (patch)
tree1ee82e6b2b22c1e3575cbc78a878ef2564ab9309 /configure.ac
parentclean up (diff)
parentMerge pull request #762 from bsdsx/explicit_bzero (diff)
downloadOpenSMTPD-4e1b8db55e04d3b03d732e8163523bfc488cc4e0.tar.xz
OpenSMTPD-4e1b8db55e04d3b03d732e8163523bfc488cc4e0.zip
Merge branch 'portable' into check_errc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f20145bd..a143d5ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -547,6 +547,14 @@ AC_SEARCH_LIBS([crypt],
])
AM_CONDITIONAL([SUPPORT_CRYPT], [test $CRYPT_SUPPORT = yes])
+EXPLICIT_BZERO_SUPPORT=no
+AC_CHECK_FUNC([explicit_bzero],
+ [
+ AC_DEFINE([HAVE_EXPLICIT_BZERO], [1],
+ [Define if you have the explicit_bzero() function.])
+ EXPLICIT_BZERO_SUPPORT=yes
+ ])
+AM_CONDITIONAL([SUPPORT_EXPLICIT_BZERO], [test $EXPLICIT_BZERO_SUPPORT = yes])
AC_CHECK_FUNCS([ \
asprintf \
@@ -558,7 +566,6 @@ AC_CHECK_FUNCS([ \
chflags \
dirfd \
endgrent \
- explicit_bzero \
fchflags \
fgetln \
freeaddrinfo \