aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGilles Chehade <gilles@poolp.org>2019-11-17 20:51:56 +0100
committerGilles Chehade <gilles@poolp.org>2019-11-17 20:51:56 +0100
commit566e49fd48a6bc7a41908cc152798a100d7fdb8d (patch)
tree1e596871637cfca7e4e26cee4d8d0d0ae417354e /configure.ac
parentconditionally build nanosec() and usleep() (diff)
downloadOpenSMTPD-566e49fd48a6bc7a41908cc152798a100d7fdb8d.tar.xz
OpenSMTPD-566e49fd48a6bc7a41908cc152798a100d7fdb8d.zip
conditionally build seteuid and setegid
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ab415578..e429e12e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -568,6 +568,8 @@ AC_CHECK_FUNCS([ \
recallocarray \
res_hnok \
setenv \
+ seteuid \
+ setegid \
setproctitle \
setregid \
setreuid \
@@ -2035,6 +2037,8 @@ AM_CONDITIONAL([NEED_PIDFILE], [test "x$ac_cv_func_pidfile" != "xyes"])
AM_CONDITIONAL([NEED_REALLOCARRAY], [test "x$ac_cv_func_reallocarray" != "xyes"])
AM_CONDITIONAL([NEED_RECALLOCARRAY], [test "x$ac_cv_func_recallocarray" != "xyes"])
AM_CONDITIONAL([NEED_SETPROCTITLE], [test "x$ac_cv_func_setproctitle" != "xyes"])
+AM_CONDITIONAL([NEED_SETEGID], [test "x$ac_cv_func_setegid" != "xyes"])
+AM_CONDITIONAL([NEED_SETEUID], [test "x$ac_cv_func_seteuid" != "xyes"])
AM_CONDITIONAL([NEED_SETRESGID], [test "x$ac_cv_func_setresgid" != "xyes"])
AM_CONDITIONAL([NEED_SETRESUID], [test "x$ac_cv_func_setresuid" != "xyes"])
AM_CONDITIONAL([NEED_SIGNAL], [test "x$ac_cv_func_signal" != "xyes"])