aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorCharles Longeau <github@chl.be>2012-07-21 18:37:39 +0200
committerCharles Longeau <github@chl.be>2012-07-21 18:37:39 +0200
commita3346478c69ff35a029382db884d53cd4d02d1a8 (patch)
tree40db778cd4b5aee2c7cbc79e00c3312438d84a78 /configure.ac
parentupdate MacOS X information from Rune Lynge (diff)
downloadOpenSMTPD-a3346478c69ff35a029382db884d53cd4d02d1a8.tar.xz
OpenSMTPD-a3346478c69ff35a029382db884d53cd4d02d1a8.zip
try to build clock_gettime() on MacOS X with -lrt, failed build reported by Rune Lynge
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 12d45a59..9952d5ca 100644
--- a/configure.ac
+++ b/configure.ac
@@ -451,6 +451,12 @@ AC_CHECK_FUNC([fparseln],
[AC_CHECK_LIB([util], [fparseln],
[LIBS="$LIBS -lutil"; AC_DEFINE([HAVE_FPARSELN])])]
)
+
+AC_CHECK_FUNC([clock_gettime],
+ [AC_DEFINE([HAVE_CLOCK_GETTIME], [1], [Define if your libraries define clock_gettime()])],
+ [AC_CHECK_LIB([rt], [clock_gettime],
+ [LIBS="$LIBS -lrt"; AC_DEFINE([HAVE_CLOCK_GETTIME])])]
+)
##chl
#l1675