aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGilles Chehade <gilles@poolp.org>2020-01-09 16:03:12 +0100
committerGilles Chehade <gilles@poolp.org>2020-01-09 16:03:12 +0100
commitb0e0529a6ac62bc96993d164fac226344ba16ac1 (patch)
treed2f91e495a18bc6c55b57deae267ecae73010d17 /configure.ac
parentMerge branch 'portable' of ssh://github.com/OpenSMTPD/OpenSMTPD into portable (diff)
downloadOpenSMTPD-b0e0529a6ac62bc96993d164fac226344ba16ac1.tar.xz
OpenSMTPD-b0e0529a6ac62bc96993d164fac226344ba16ac1.zip
properly check res_hnok in configure.ac
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d485da5e..2e258082 100644
--- a/configure.ac
+++ b/configure.ac
@@ -476,6 +476,13 @@ AC_SEARCH_LIBS([fparseln],
[Define if you have the fparseln() function.])
])
+AC_SEARCH_LIBS([res_hnok],
+ [resolv],
+ [
+ AC_DEFINE([HAVE_RES_HNOK], [1],
+ [Define if you have the res_hnok() function.])
+ ])
+
AC_SEARCH_LIBS([res_randomid],
[resolv],
[
@@ -2027,6 +2034,7 @@ AM_CONDITIONAL([NEED_WAITPID], [test "x$ac_cv_func_waitpid" != "xyes"])
AM_CONDITIONAL([NEED_VIS], [test "x$ac_cv_func_strnvis" != "xyes" -o "x$BROKEN_STRNVIS" = "x1"])
AM_CONDITIONAL([NEED_USLEEP], [test "x$ac_cv_func_usleep" != "xyes"])
+AM_CONDITIONAL([NEED_RES_HNOK], [test "x$ac_cv_search_res_hnok" = "xno" -a x"$ac_cv_func_res_hnok" != "xyes" -a x"$need_libasr" = x"yes"])
AM_CONDITIONAL([NEED_RES_RANDOMID], [test "x$ac_cv_search_res_randomid" = "xno" -a x"$ac_cv_func_res_randomid" != "xyes" -a x"$need_libasr" = x"yes"])
AM_CONDITIONAL([NEED_ARC4RANDOM], [test "x$ac_cv_func_arc4random" != "xyes" -a "x$ac_cv_have_decl_LIBRESSL_VERSION_NUMBER" != "xyes"])