aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorGilles Chehade <gilles@poolp.org>2019-11-10 08:19:00 +0000
committerGilles Chehade <gilles@poolp.org>2019-11-10 08:19:00 +0000
commitf091ec31bd85f4fa69b147a2cfa83e5aeb5a6c06 (patch)
treee0efce08d62019dabf967f03b2fbe5e8057e497a /configure.ac
parent_decl_ -> _ (diff)
downloadOpenSMTPD-f091ec31bd85f4fa69b147a2cfa83e5aeb5a6c06.tar.xz
OpenSMTPD-f091ec31bd85f4fa69b147a2cfa83e5aeb5a6c06.zip
fix build
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 28 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index af488bdf..386b698d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2001,47 +2001,46 @@ LIBS="$LIBS ${SMTPDLIBS}"
##
-AM_CONDITIONAL([NEED_BASENAME], [test "x$ac_cv_have_basename" = "xno"])
+AM_CONDITIONAL([NEED_BASENAME], [test "x$ac_cv_have_basename" != "xyes"])
-AM_CONDITIONAL([NEED_ERRC], [test "x$ac_cv_have_errc" = "xno"])
+AM_CONDITIONAL([NEED_ERRC], [test "x$ac_cv_have_errc" != "xyes"])
-AM_CONDITIONAL([NEED_CLOSEFROM], [test "x$ac_cv_have_closefrom" = "xno"])
-AM_CONDITIONAL([NEED_CRYPT_CHECKPASS], [test "x$ac_cv_have_crypt_checkpass" = "xno"])
-AM_CONDITIONAL([NEED_CLOCK_GETTIME], [test "x$ac_cv_have_clock_gettime" = "xno"])
+AM_CONDITIONAL([NEED_CLOSEFROM], [test "x$ac_cv_have_closefrom" != "xyes"])
+AM_CONDITIONAL([NEED_CRYPT_CHECKPASS], [test "x$ac_cv_have_crypt_checkpass" != "xyes"])
+AM_CONDITIONAL([NEED_CLOCK_GETTIME], [test "x$ac_cv_have_clock_gettime" != "xyes"])
-AM_CONDITIONAL([NEED_DAEMON], [test "x$ac_cv_have_daemon" = "xno"])
-AM_CONDITIONAL([NEED_DIRNAME], [test "x$ac_cv_have_dirname" = "xno"])
+AM_CONDITIONAL([NEED_DAEMON], [test "x$ac_cv_have_daemon" != "xyes"])
+AM_CONDITIONAL([NEED_DIRNAME], [test "x$ac_cv_have_dirname" != "xyes"])
-AM_CONDITIONAL([NEED_EXPLICIT_BZERO], [test "x$ac_cv_have_explicit_bzero" = "xno"])
+AM_CONDITIONAL([NEED_EXPLICIT_BZERO], [test "x$ac_cv_have_explicit_bzero" != "xyes"])
-AM_CONDITIONAL([NEED_FGETLN], [test "x$ac_cv_have_fgetln" = "xno"])
-AM_CONDITIONAL([NEED_FLOCK], [test "x$ac_cv_have_flock" = "xno"])
-AM_CONDITIONAL([NEED_FMT_SCALED], [test "x$ac_cv_have_fmt_scaled" = "xno"])
-AM_CONDITIONAL([NEED_FPARSELN], [test "x$ac_cv_have_fparseln" = "xno"])
-AM_CONDITIONAL([NEED_FREEZERO], [test "x$ac_cv_have_freezero" = "xno"])
+AM_CONDITIONAL([NEED_FGETLN], [test "x$ac_cv_have_fgetln" != "xyes"])
+AM_CONDITIONAL([NEED_FMT_SCALED], [test "x$ac_cv_have_fmt_scaled" != "xyes"])
+AM_CONDITIONAL([NEED_FPARSELN], [test "x$ac_cv_have_fparseln" != "xyes"])
+AM_CONDITIONAL([NEED_FREEZERO], [test "x$ac_cv_have_freezero" != "xyes"])
-AM_CONDITIONAL([NEED_GETLINE], [test "x$ac_cv_have_getline" = "xno"])
+#AM_CONDITIONAL([NEED_GETLINE], [test "x$ac_cv_have_getline" != "xyes"])
-AM_CONDITIONAL([NEED_IMSG], [test "x$ac_cv_have_imsg_init" = "xno"])
-AM_CONDITIONAL([NEED_INET_NET_PTON], [test "x$ac_cv_have_inet_net_pton" = "xno"])
+AM_CONDITIONAL([NEED_IMSG], [test "x$ac_cv_have_imsg_init" != "xyes"])
+AM_CONDITIONAL([NEED_INET_NET_PTON], [test "x$ac_cv_have_inet_net_pton" != "xyes"])
-AM_CONDITIONAL([NEED_PIDFILE], [test "x$ac_cv_have_pidfile" = "xno"])
-AM_CONDITIONAL([NEED_PW_DUP], [test "x$ac_cv_have_pw_dup" = "xno"])
+AM_CONDITIONAL([NEED_PIDFILE], [test "x$ac_cv_have_pidfile" != "xyes"])
+AM_CONDITIONAL([NEED_PW_DUP], [test "x$ac_cv_have_pw_dup" != "xyes"])
-AM_CONDITIONAL([NEED_REALLOCARRAY], [test "x$ac_cv_have_reallocarray" = "xno"])
-AM_CONDITIONAL([NEED_RECALLOCARRAY], [test "x$ac_cv_have_recallocarray" = "xno"])
+AM_CONDITIONAL([NEED_REALLOCARRAY], [test "x$ac_cv_have_reallocarray" != "xyes"])
+AM_CONDITIONAL([NEED_RECALLOCARRAY], [test "x$ac_cv_have_recallocarray" != "xyes"])
-AM_CONDITIONAL([NEED_SETRESGID], [test "x$ac_cv_have_setresgid" = "xno"])
-AM_CONDITIONAL([NEED_SETRESUID], [test "x$ac_cv_have_strresuid" = "xno"])
+AM_CONDITIONAL([NEED_SETRESGID], [test "x$ac_cv_have_setresgid" != "xyes"])
+AM_CONDITIONAL([NEED_SETRESUID], [test "x$ac_cv_have_strresuid" != "xyes"])
-AM_CONDITIONAL([NEED_STRLCAT], [test "x$ac_cv_have_strlcat" = "xno"])
-AM_CONDITIONAL([NEED_STRLCPY], [test "x$ac_cv_have_strlcpy" = "xno"])
-AM_CONDITIONAL([NEED_STRMODE], [test "x$ac_cv_have_strmode" = "xno"])
-AM_CONDITIONAL([NEED_STRSEP], [test "x$ac_cv_have_strsep" = "xno"])
-AM_CONDITIONAL([NEED_STRTONUM], [test "x$ac_cv_have_strtonum" = "xno"])
-AM_CONDITIONAL([NEED_STRNDUP], [test "x$ac_cv_have_strndup" = "xno"])
-AM_CONDITIONAL([NEED_STRNLEN], [test "x$ac_cv_have_strnlen" = "xno"])
+AM_CONDITIONAL([NEED_STRLCAT], [test "x$ac_cv_have_strlcat" != "xyes"])
+AM_CONDITIONAL([NEED_STRLCPY], [test "x$ac_cv_have_strlcpy" != "xyes"])
+AM_CONDITIONAL([NEED_STRMODE], [test "x$ac_cv_have_strmode" != "xyes"])
+AM_CONDITIONAL([NEED_STRSEP], [test "x$ac_cv_have_strsep" != "xyes"])
+AM_CONDITIONAL([NEED_STRTONUM], [test "x$ac_cv_have_strtonum" != "xyes"])
+AM_CONDITIONAL([NEED_STRNDUP], [test "x$ac_cv_have_strndup" != "xyes"])
+AM_CONDITIONAL([NEED_STRNLEN], [test "x$ac_cv_have_strnlen" != "xyes"])
##