aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f45d789b..a143d5ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -441,6 +441,15 @@ AC_SEARCH_LIBS([dirname],
])
AM_CONDITIONAL([SUPPORT_DIRNAME], [test $DIRNAME_SUPPORT = yes])
+ERRC_SUPPORT=no
+AC_CHECK_FUNC([errc],
+ [
+ AC_DEFINE([HAVE_ERRC], [1],
+ [Define if you have the errc() function.])
+ ERRC_SUPPORT=yes
+ ])
+AM_CONDITIONAL([SUPPORT_ERRC], [test $ERRC_SUPPORT = yes])
+
INET_NET_PTON_SUPPORT=no
AC_SEARCH_LIBS([inet_net_pton],
[resolv],