aboutsummaryrefslogtreecommitdiffstats
path: root/openbsd-compat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'openbsd-compat/Makefile.am')
-rw-r--r--openbsd-compat/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/openbsd-compat/Makefile.am b/openbsd-compat/Makefile.am
index d58f901d..a43dff55 100644
--- a/openbsd-compat/Makefile.am
+++ b/openbsd-compat/Makefile.am
@@ -83,6 +83,14 @@ if !SUPPORT_INET_NET_PTON
libopenbsd_compat_a_SOURCES += inet_net_pton.c
endif
+if !SUPPORT_STRNDUP
+libopenbsd_compat_a_SOURCES += strndup.c
+endif
+
+if !SUPPORT_STRNLEN
+libopenbsd_compat_a_SOURCES += strnlen.c
+endif
+
EXTRA_DIST = base64.h
EXTRA_DIST += bsd-misc.h
EXTRA_DIST += bsd-waitpid.h