summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-02-22 05:37:46 -0800
committerZac Medico <zmedico@gentoo.org>2021-02-22 05:38:00 -0800
commit3dcb1e39ad3f2c55dd095abf72b9aa0b14b3aa5e (patch)
tree838be20a89d2f965697775c3647f180151dac68e
parentmake.globals: default enable FEATURES=binpkg-multi-instance (diff)
downloadgentoo-portage-3dcb1e39ad3f2c55dd095abf72b9aa0b14b3aa5e.tar.xz
gentoo-portage-3dcb1e39ad3f2c55dd095abf72b9aa0b14b3aa5e.zip
Updates for portage-3.0.15 releaseportage-3.0.15
Signed-off-by: Zac Medico <zmedico@gentoo.org>
-rw-r--r--NEWS5
-rw-r--r--RELEASE-NOTES12
-rwxr-xr-xsetup.py4
3 files changed, 19 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 685e42b2c..99839807c 100644
--- a/NEWS
+++ b/NEWS
@@ -1,5 +1,10 @@
News (mainly features/major bug fixes)
+
+portage-3.0.15
+--------------
+* FEATURES=binpkg-multi-instance is now enabled by default.
+
portage-3.0.13
--------------
* FETCHCOMMAND now supports a \${DIGESTS} placeholder which expands
diff --git a/RELEASE-NOTES b/RELEASE-NOTES
index 430b24a64..ced60eec2 100644
--- a/RELEASE-NOTES
+++ b/RELEASE-NOTES
@@ -1,6 +1,18 @@
Release Notes; upgrade information mainly.
Features/major bugfixes are listed in NEWS
+portage-3.0.15
+==================================
+* Bug Fixes:
+ - Bug 715112 default enable FEATURES=binpkg-multi-instance
+ - Bug 756778 content-hash distfiles layout
+ - Bug 766459 emirrordist: prevent distfiles_db _pkg_str pickle problems
+ - Bug 766767 emaint --fix merges: add -y, --yes option
+ - Bug 766773 emerge: disable --autounmask-license by default
+ - Bug 767913 portage.getpid: call os.getpid() lazily
+ - Bug 770712 PopenProcess: use call_soon for _async_waipid in _start
+ - Bug 771549 prevent USE="${USE} ..." misbehavior
+
portage-3.0.14
==================================
* Bug Fixes:
diff --git a/setup.py b/setup.py
index 5bd899e2c..2617c10ad 100755
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,5 @@
#!/usr/bin/env python
-# Copyright 1998-2020 Gentoo Authors
+# Copyright 1998-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
from distutils.core import setup, Command, Extension
@@ -655,7 +655,7 @@ class build_ext(_build_ext):
setup(
name = 'portage',
- version = '3.0.14',
+ version = '3.0.15',
url = 'https://wiki.gentoo.org/wiki/Project:Portage',
author = 'Gentoo Portage Development Team',
author_email = 'dev-portage@gentoo.org',