aboutsummaryrefslogtreecommitdiffstats
path: root/drivers/infiniband/Kconfig
diff options
context:
space:
mode:
authorLeon Romanovsky <leonro@mellanox.com>2018-05-23 08:22:11 +0300
committerJason Gunthorpe <jgg@mellanox.com>2018-05-24 09:39:25 -0600
commit7a8690ed6f5346f6738971892205e91d39b6b901 (patch)
treea6fca563173b4c15d0f14de204cad9fb1a9eee29 /drivers/infiniband/Kconfig
parentIB/core: Remove duplicate declaration of gid_cache_wq (diff)
downloadlinux-dev-7a8690ed6f5346f6738971892205e91d39b6b901.tar.xz
linux-dev-7a8690ed6f5346f6738971892205e91d39b6b901.zip
RDMA/ucm: Mark UCM interface as BROKEN
In commit 357d23c811a7 ("Remove the obsolete libibcm library") in rdma-core [1], we removed obsolete library which used the /dev/infiniband/ucmX interface. Following multiple syzkaller reports about non-sanitized user input in the UCMA module, the short audit reveals the same issues in UCM module too. It is better to disable this interface in the kernel, before syzkaller team invests time and energy to harden this unused interface. [1] https://github.com/linux-rdma/rdma-core/pull/279 Signed-off-by: Leon Romanovsky <leonro@mellanox.com> Signed-off-by: Jason Gunthorpe <jgg@mellanox.com>
Diffstat (limited to 'drivers/infiniband/Kconfig')
-rw-r--r--drivers/infiniband/Kconfig11
1 files changed, 11 insertions, 0 deletions
diff --git a/drivers/infiniband/Kconfig b/drivers/infiniband/Kconfig
index 2a972ed6851b..b03af54367c0 100644
--- a/drivers/infiniband/Kconfig
+++ b/drivers/infiniband/Kconfig
@@ -35,6 +35,17 @@ config INFINIBAND_USER_ACCESS
libibverbs, libibcm and a hardware driver library from
rdma-core <https://github.com/linux-rdma/rdma-core>.
+config INFINIBAND_USER_ACCESS_UCM
+ bool "Userspace CM (UCM, DEPRECATED)"
+ depends on BROKEN
+ depends on INFINIBAND_USER_ACCESS
+ help
+ The UCM module has known security flaws, which no one is
+ interested to fix. The user-space part of this code was
+ dropped from the upstream a long time ago.
+
+ This option is DEPRECATED and planned to be removed.
+
config INFINIBAND_EXP_LEGACY_VERBS_NEW_UAPI
bool "Allow experimental legacy verbs in new ioctl uAPI (EXPERIMENTAL)"
depends on INFINIBAND_USER_ACCESS