path: root/sound/pci/hda/patch_via.c (unfollow)
AgeCommit message (Expand)AuthorFilesLines
2020-01-13ALSA: hda: Manage concurrent reg access more properlyTakashi Iwai1-1/+1
2020-01-03ALSA: hda - constify and cleanup static NodeID tablesMichał Mirosław1-2/+2
2019-05-24treewide: Replace GPLv2 boilerplate/reference with SPDX - rule 32Thomas Gleixner1-14/+1
2018-08-30ALSA: hda: move hda_codec.h to include/soundPierre-Louis Bossart1-1/+1
2018-08-28ALSA: hda: move hda_codec.h to include/soundPierre-Louis Bossart1-1/+1
2018-06-25ALSA: hda/via - Use standard verb containersTakashi Iwai1-29/+35
2018-06-25ALSA: hda/via - Simplify control managementTakashi Iwai1-86/+44
2018-06-25ALSA: hda/via - Rewrite with error gotoTakashi Iwai1-40/+60
2015-10-20ALSA: hda - convert to hda_device_idTakashi Iwai1-99/+54
2015-10-15ALSA: hda - consolidate chip rename functionsTakashi Iwai1-14/+4
2015-06-25ALSA: hda - Disable widget power-save for VIA codecsTakashi Iwai1-3/+5
2015-05-31ALSA: hda - Fix jack detection at resume with VT codecsTakashi Iwai1-0/+10
2015-05-29ALSA: hda - Set patch_ops before calling auto-parserTakashi Iwai1-15/+6
2015-05-29ALSA: hda - Fix lost sound due to stream_pm ops cleanupTakashi Iwai1-0/+1
2015-05-27ALSA: hda - Set stream_pm ops automatically by generic parserTakashi Iwai1-1/+0
2015-04-09ALSA: hda/via - Add missing stream_pm ops setupTakashi Iwai1-0/+1
2015-03-25ALSA: hda/via - Add beep controls to VIA codecsW. Trevor King1-0/+61
2015-03-23ALSA: hda - Move a part of hda_codec stuff into hdac_deviceTakashi Iwai1-12/+11
2015-03-20ALSA: hda - Rename power_mgmt flag with power_save_nodeTakashi Iwai1-6/+6
2015-03-18ALSA: hda - Use the new power control for VIA codecsTakashi Iwai1-650/+12
2015-03-03ALSA: hda - Use standard workqueue for unsol and jack eventsTakashi Iwai1-2/+1
2015-03-03ALSA: hda - Allocate hda_pcm objects dynamicallyTakashi Iwai1-2/+4
2015-03-03ALSA: hda - Add card field to hda_codec structTakashi Iwai1-4/+4
2015-02-23ALSA: hda - Bind codecs via standard busTakashi Iwai1-14/+2
2014-12-15ALSA: hda - Make add_stereo_mix_input flag tristateTakashi Iwai1-1/+1
2014-09-16ALSA: hda - Remove superfluous hooks from VIA driverTakashi Iwai1-23/+2
2014-09-16ALSA: hda - Allow multiple callbacks for jackTakashi Iwai1-4/+7
2014-09-11ALSA: hda - Get rid of action field from struct hda_jack_tblTakashi Iwai1-4/+0
2014-02-10ALSA: hda - Make snd_hda_gen_spec_free() staticTakashi Iwai1-7/+1
2013-12-09ALSA: hda - Enable stereo mix as default for AD and VIA codecsTakashi Iwai1-0/+1
2013-07-29ALSA: hda - Clearing jackpoll_interval avoid pending workWang Xingchao1-1/+1
2013-06-25ALSA: hda - Use auto_mute_via_amp=1 for VT1708Takashi Iwai1-0/+2
2013-06-19ALSA: hda - Fix missing Mic Boost controls for VIA codecsTakashi Iwai1-0/+2
2013-06-05ALSA: hda/via - Use standard snd_hda_shutup_pins()Takashi Iwai1-8/+3
2013-06-03ALSA: hda/via - Fix wrongly cleared pins after suspend on VT1802Takashi Iwai1-1/+3
2013-06-03ALSA: hda - Add keep_eapd_on flag to generic parserTakashi Iwai1-0/+1
2013-06-03ALSA: hda/via - Disable broken dynamic power controlTakashi Iwai1-0/+5
2013-03-22ALSA: hda - VIA prefers side surrounds over HPTakashi Iwai1-0/+20
2013-02-07ALSA: hda - Use generic array for loopback list managementTakashi Iwai1-3/+5
2013-02-05ALSA: hda - detect jacks on VT1708 even when no streams are activeDavid Henningsson1-2/+1
2013-02-05ALSA: hda - Fix phantom jacks on VT1708David Henningsson1-0/+13
2013-01-24ALSA: hda - Add snd_hda_check_power_state() helper functionTakashi Iwai1-8/+3
2013-01-24ALSA: hda/via - Fix wrong checks of power state bitsTakashi Iwai1-4/+8
2013-01-21ALSA: hda - Enable parsing the independent HP mode as default for VIA codecsTakashi Iwai1-0/+1
2013-01-12ALSA: hda - Use generic parser for VIA codec driverTakashi Iwai1-2405/+205
2013-01-12ALSA: hda - Rearrange INPUT_PIN_ATTR_*Takashi Iwai1-1/+1
2013-01-12ALSA: hda - Move fixup code into struct hda_codecTakashi Iwai1-4/+0
2012-12-10ALSA: HDA: VIA: Add support for codec VT1808.Lydia Wang1-0/+8
2012-12-10ALSA: HDA: VIA Add support for codec VT1705CF.Lydia Wang1-0/+151
2012-11-30ALSA: hda - Add a helper function for simple enum kcontrolsTakashi Iwai1-12/+1