summaryrefslogtreecommitdiffstats
path: root/net-misc/vidalia/vidalia-0.3.1-r1.ebuild
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2012-08-08 18:07:08 +0200
committerJason A. Donenfeld <Jason@zx2c4.com>2012-08-08 18:07:08 +0200
commita0b939d33b2429985ea04a5c39a1323723378ca1 (patch)
treee3798ac7ca147e69966b88ca992aa60c2059cbb2 /net-misc/vidalia/vidalia-0.3.1-r1.ebuild
parentAdd patch so that ptlib builds on gcc 4.7. This fixes bug #420077. (diff)
downloadportage-a0b939d33b2429985ea04a5c39a1323723378ca1.tar.xz
portage-a0b939d33b2429985ea04a5c39a1323723378ca1.zip
Build vidalia on gcc 4.7. This fixes bug #422645.
Diffstat (limited to '')
-rw-r--r--net-misc/vidalia/vidalia-0.3.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/vidalia/vidalia-0.3.1-r1.ebuild b/net-misc/vidalia/vidalia-0.3.1-r1.ebuild
new file mode 100644
index 0000000..b48cc84
--- /dev/null
+++ b/net-misc/vidalia/vidalia-0.3.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/vidalia/vidalia-0.3.1.ebuild,v 1.1 2012/03/27 15:28:42 blueness Exp $
+
+EAPI="4"
+
+# cmake-utils needs to be last, so we get its src_compile()
+inherit eutils qt4-r2 cmake-utils
+
+DESCRIPTION="Qt 4 front-end for Tor"
+HOMEPAGE="https://www.torproject.org/projects/vidalia.html.en"
+SRC_URI="https://www.torproject.org/dist/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-3 GPL-2 ) openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug +tor"
+
+DEPEND="x11-libs/qt-gui:4[debug?]"
+RDEPEND="${DEPEND}
+ tor? ( net-misc/tor )"
+
+DOCS="CHANGELOG CREDITS README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.3.1-gcc-4.7.patch
+}
+
+pkg_postinst() {
+ ewarn
+ if use tor; then
+ ewarn "To have vidalia starting tor, you probably have to copy"
+ ewarn "/etc/tor/torrc.sample to the users ~/.tor/torrc and comment"
+ ewarn "the settings there and change the socks. Also, in vidalia"
+ ewarn "change the default user under which tor will run."
+ else
+ ewarn "You have disabled tor USE flag, which means you need to "
+ ewarn "configure tor on a different host."
+ fi
+ ewarn
+}