summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-19 11:35:01 +0100
committerZbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl>2017-12-21 17:01:02 +0100
commit37e4d7a8553c6f43217950fa428ac270378c20b0 (patch)
tree0978b8620aa55c2533d5b82e0454f5f6f32ef2c5 /meson.build
parentsd-bus: drop check for selinux before calling getsockopt(SO_PEERSEC) (diff)
downloadsystemd-37e4d7a8553c6f43217950fa428ac270378c20b0.tar.xz
systemd-37e4d7a8553c6f43217950fa428ac270378c20b0.zip
meson: rename libsystemd_internal to libsystem_static
We already use the "_static" suffix for libshared_static ("shared" is the name of the library, "static" is the format) and other libs, so let's rename for consistency. Also change libsystemd_static_sources to libsystemd_sources, since the same list is used for both and shorter is better.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 3 insertions, 3 deletions
diff --git a/meson.build b/meson.build
index 11b73bcb199..9dabf342d23 100644
--- a/meson.build
+++ b/meson.build
@@ -1258,7 +1258,7 @@ libjournal_core = static_library(
libsystemd_sym_path = '@0@/@1@'.format(meson.current_source_dir(), libsystemd_sym)
libsystemd = shared_library(
'systemd',
- libsystemd_internal_sources,
+ libsystemd_sources,
journal_internal_sources,
version : libsystemd_version,
include_directories : includes,
@@ -1338,7 +1338,7 @@ foreach tuple : [['myhostname', 'ENABLE_MYHOSTNAME'],
'-shared',
'-Wl,--version-script=' + version_script_arg,
'-Wl,--undefined'],
- link_with : [libsystemd_internal,
+ link_with : [libsystemd_static,
libbasic],
dependencies : [threads,
librt],
@@ -1576,7 +1576,7 @@ if conf.get('ENABLE_LOGIND') == 1
include_directories : includes,
link_args : ['-shared',
'-Wl,--version-script=' + version_script_arg],
- link_with : [libsystemd_internal,
+ link_with : [libsystemd_static,
libshared_static],
dependencies : [threads,
libpam,