summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2017-12-20 12:51:14 +0100
committerLennart Poettering <lennart@poettering.net>2018-01-05 13:58:33 +0100
commit51b13863a2d64fa7c8da8006c4d345e08f9986c2 (patch)
treee7f6eb01937300c666461b7c43ce67c3cf329ce2 /meson.build
parentsd-bus: remove 'hint_sync_call' parameter from various function calls (diff)
downloadsystemd-51b13863a2d64fa7c8da8006c4d345e08f9986c2.tar.xz
systemd-51b13863a2d64fa7c8da8006c4d345e08f9986c2.zip
meson: resurrect API documentation target
We had this functionality back in Automake times, let's resurrect it.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index f95feee99de..924274de630 100644
--- a/meson.build
+++ b/meson.build
@@ -2556,6 +2556,14 @@ endif
############################################################
+meson_check_api_docs_sh = find_program('tools/meson-check-api-docs.sh')
+run_target(
+ 'check-api-docs',
+ depends : [man, libsystemd, libudev],
+ command : [meson_check_api_docs_sh, libsystemd.full_path(), libudev.full_path()])
+
+############################################################
+
status = [
'@0@ @1@'.format(meson.project_name(), meson.project_version()),