summaryrefslogtreecommitdiffstats
path: root/meson.build
diff options
context:
space:
mode:
authortblume <Thomas.Blume@suse.com>2018-02-01 22:46:15 +0100
committerYu Watanabe <watanabe.yu+github@gmail.com>2018-02-02 06:46:15 +0900
commit75aaade16b00ff519fbaedb4cc773b654c11a34a (patch)
treea7de0b9a1f32e8184cabba8a905a56e1e00e1e69 /meson.build
parentMerge pull request #7042 from vcaputo/iteratedcache (diff)
downloadsystemd-75aaade16b00ff519fbaedb4cc773b654c11a34a.tar.xz
systemd-75aaade16b00ff519fbaedb4cc773b654c11a34a.zip
meson.build: make docdir configurable (#8068)
SUSE is using a different docdir, so the path should be configurable
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 5 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 36a62d280df..e497924cb80 100644
--- a/meson.build
+++ b/meson.build
@@ -136,13 +136,17 @@ udevhwdbdir = join_paths(udevlibexecdir, 'hwdb.d')
catalogdir = join_paths(prefixdir, 'lib/systemd/catalog')
kernelinstalldir = join_paths(prefixdir, 'lib/kernel/install.d')
factorydir = join_paths(datadir, 'factory')
-docdir = join_paths(datadir, 'doc/systemd')
bootlibdir = join_paths(prefixdir, 'lib/systemd/boot/efi')
testsdir = join_paths(prefixdir, 'lib/systemd/tests')
systemdstatedir = join_paths(localstatedir, 'lib/systemd')
catalogstatedir = join_paths(systemdstatedir, 'catalog')
randomseeddir = join_paths(localstatedir, 'lib/systemd')
+docdir = get_option('docdir')
+if docdir == ''
+ docdir = join_paths(datadir, 'doc/systemd')
+endif
+
dbuspolicydir = get_option('dbuspolicydir')
if dbuspolicydir == ''
dbuspolicydir = join_paths(datadir, 'dbus-1/system.d')