aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/app/tools/CMakeLists.txt
diff options
context:
space:
mode:
authorNicolas Douma <nicolas@serveur.io>2019-10-04 16:58:58 +0200
committerJason A. Donenfeld <Jason@zx2c4.com>2019-10-12 18:55:28 +0200
commitd0d24f4554812c7d6a91785a6190791e02e6e56c (patch)
tree9cd723d09d7188549f9d5dae7c5cca8a999055d1 /app/tools/CMakeLists.txt
parentActivity: make dark/night theme follow system on Q (diff)
downloadwireguard-android-d0d24f4554812c7d6a91785a6190791e02e6e56c.tar.xz
wireguard-android-d0d24f4554812c7d6a91785a6190791e02e6e56c.zip
tools: prepare for binder usage in wg-quick
Signed-off-by: Nicolas Douma <nicolas@serveur.io> Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
Diffstat (limited to 'app/tools/CMakeLists.txt')
-rw-r--r--app/tools/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/app/tools/CMakeLists.txt b/app/tools/CMakeLists.txt
index 41060ea1..2a04901f 100644
--- a/app/tools/CMakeLists.txt
+++ b/app/tools/CMakeLists.txt
@@ -9,7 +9,8 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_LIBRARY_OUTPUT_DIRECTORY}")
set(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -fuse-ld=gold")
add_executable(libwg-quick.so wireguard/src/tools/wg-quick/android.c ndk-compat/compat.c)
-target_compile_options(libwg-quick.so PUBLIC -O3 -std=gnu11 -Wall -pedantic -Wno-missing-field-initializers -include ${CMAKE_CURRENT_SOURCE_DIR}/ndk-compat/compat.h -DWG_PACKAGE_NAME=\"${ANDROID_PACKAGE_NAME}\")
+target_compile_options(libwg-quick.so PUBLIC -O3 -std=gnu11 -Wall -include ${CMAKE_CURRENT_SOURCE_DIR}/ndk-compat/compat.h -DWG_PACKAGE_NAME=\"${ANDROID_PACKAGE_NAME}\")
+target_link_libraries(libwg-quick.so -ldl)
file(GLOB WG_SOURCES wireguard/src/tools/*.c libmnl/src/*.c ndk-compat/compat.c)
add_executable(libwg.so ${WG_SOURCES})