summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2019-08-26 15:00:14 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2019-08-26 15:00:14 +0200
commit5f3c4d2e276792b99449cba6a04520ee1d324bbf (patch)
treee8dee95e8e2db3724372e75a0d4f095770aed7a6 /Cargo.toml
parentMove to hjul crate (diff)
downloadwireguard-rs-5f3c4d2e276792b99449cba6a04520ee1d324bbf.tar.xz
wireguard-rs-5f3c4d2e276792b99449cba6a04520ee1d324bbf.zip
Update the blake2 crate to fix bug upstream
Included basic sanity check for the HKDF macroes, to avoid regression in future.
Diffstat (limited to '')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cfd15db..0dc9cb6 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -9,7 +9,7 @@ license = "MIT"
hex = "0.3"
spin = "0.5.0"
rand = "0.6.5"
-blake2 = "0.8.0"
+blake2 = "0.8"
hmac = "0.7.1"
generic-array = "0.12.3"
zerocopy = "0.2.7"
@@ -22,7 +22,7 @@ futures = "0.1.28"
arraydeque = "^0.4"
treebitmap = "^0.4"
crossbeam-deque = "0.7"
-hjul = "0.1.0"
+hjul = "0.1.2"
[dependencies.x25519-dalek]
version = "^0.5"