aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-03-09 04:50:00 +0000
committerJake McGinty <me@jake.su>2018-03-09 04:50:00 +0000
commita5bad2984b404b91670bbb634c79102b476a0b5a (patch)
tree5a445edb8fe02fed379807e2170c2a7489b29524 /Cargo.toml
parentglobal: tidying up (diff)
downloadwireguard-rs-a5bad2984b404b91670bbb634c79102b476a0b5a.tar.xz
wireguard-rs-a5bad2984b404b91670bbb634c79102b476a0b5a.zip
peer: zero out sessions when they're dropped
NOTE: I'm not entirely sure this is sufficient, but it's a start.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2950455..6d3031e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,6 +34,7 @@ blake2-rfc = "0.2"
byteorder = "^1.2"
bytes = "0.4"
chacha20-poly1305-aead = "^0.1"
+clear_on_drop = "^0.2"
derive_deref = "^1.0"
failure = "^0.1"
futures = "^0.1"