aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-03-01 20:56:05 +0000
committerJake McGinty <me@jake.su>2018-03-04 01:23:31 +0000
commita99105ffc21caf8ea5fc6c662efe5cc27a76ae7f (patch)
tree2173517522a2d5bbec8e4d347b3586d42ba6fb8c /Cargo.toml
parentglobal: clean up logging, stop using env_logger (diff)
downloadwireguard-rs-a99105ffc21caf8ea5fc6c662efe5cc27a76ae7f.tar.xz
wireguard-rs-a99105ffc21caf8ea5fc6c662efe5cc27a76ae7f.zip
udp: switch to own tokio UdpSocket implementation for performance reasons
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 298c792..36aa823 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,6 +42,7 @@ hex = "^0.3"
notify = "4.0.0"
rand = "^0.4"
nix = "^0.10"
+mio = "^0.6"
pnet_packet = "^0.20"
snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
socket2 = "^0.3"