aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-02-15 02:56:16 +0000
committerJake McGinty <me@jake.su>2018-02-15 02:56:16 +0000
commit0e174403efaef446c39dfbec8263fa25439a303c (patch)
treeebea8ebc489301df9e77075b5fce8bbb8cd009dd /Cargo.toml
parentswitch to lib/bin hybrid crate (diff)
downloadwireguard-rs-0e174403efaef446c39dfbec8263fa25439a303c.tar.xz
wireguard-rs-0e174403efaef446c39dfbec8263fa25439a303c.zip
add initial criterion benchmarks
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 8e5616e..e41c495 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -17,6 +17,13 @@ path = "src/main.rs"
[profile.release]
debug = true
+[dev-dependencies]
+criterion = "0.2.0"
+
+[[bench]]
+name = "criterion"
+harness = false
+
[dependencies]
base64 = "^0.5"
blake2-rfc = "0.2"