aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-03-01 19:57:47 +0000
committerJake McGinty <me@jake.su>2018-03-04 01:23:25 +0000
commit295c7438c381ca2dae628d47a9b77138f7d413cd (patch)
tree802b140da4d03a8f9df315ecd4f41473d642250e /Cargo.toml
parentpeer: smaller allocations for incoming messages (diff)
downloadwireguard-rs-295c7438c381ca2dae628d47a9b77138f7d413cd.tar.xz
wireguard-rs-295c7438c381ca2dae628d47a9b77138f7d413cd.zip
global: clean up logging, stop using env_logger
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml12
1 files changed, 7 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 96805ea..298c792 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -13,10 +13,10 @@ path = "src/lib.rs"
[[bin]]
name = "wgrs"
path = "src/main.rs"
-required-features = ["build-binary"]
+required-features = ["binary"]
[features]
-build-binary = [ "daemonize", "structopt", "structopt-derive" ]
+binary = [ "daemonize", "structopt", "structopt-derive", "fern", "chrono", "colored" ]
[profile.release]
debug = true
@@ -34,11 +34,10 @@ blake2-rfc = "0.2"
byteorder = "^1.2"
bytes = "0.4"
chacha20-poly1305-aead = "^0.1"
-env_logger = "^0.4"
failure = "^0.1"
futures = "^0.1"
lazy_static = "^1"
-log = "^0.3"
+log = "^0.4"
hex = "^0.3"
notify = "4.0.0"
rand = "^0.4"
@@ -56,6 +55,9 @@ tokio-signal = "^0.1"
treebitmap = "^0.2"
x25519-dalek = "^0.1"
-daemonize = { git = "https://github.com/mcginty/daemonize", version = "0.2", optional = true }
+daemonize = { git = "https://github.com/mcginty/daemonize", optional = true }
+chrono = { version = "^0.4", optional = true }
+colored = { version = "^1.6", optional = true }
structopt = { version = "^0.1", optional = true }
structopt-derive = { version = "^0.1", optional = true }
+fern = { version = "^0.5", features = ["colored"], optional = true }