aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-02-08 15:23:13 +0000
committerJake McGinty <me@jake.su>2018-02-08 15:23:20 +0000
commit34ba2cd5c5826d8d01c580b05e4c9a883f8a12a9 (patch)
tree07c25501172f4f7b07594de792cfb7075e230f36 /Cargo.toml
parenttake advantage of new snow API (diff)
downloadwireguard-rs-34ba2cd5c5826d8d01c580b05e4c9a883f8a12a9.tar.xz
wireguard-rs-34ba2cd5c5826d8d01c580b05e4c9a883f8a12a9.zip
drop error-chain in favor of Failure crate
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 14 insertions, 18 deletions
diff --git a/Cargo.toml b/Cargo.toml
index b1c0e94..bb79d27 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -7,33 +7,29 @@ repository = "https://git.zx2c4.com/wireguard-rs/"
description = "Userspace implementation of WireGuard, a fast, modern and secure VPN tunnel."
[dependencies]
+base64 = "^0.5"
blake2-rfc = "0.2"
byteorder = "^1.2"
-structopt = "^0.1"
-structopt-derive = "^0.1"
+bytes = "0.4"
daemonize = "0.2"
-error-chain = "^0.11"
+env_logger = "^0.4"
+failure = "^0.1"
+futures = "^0.1"
+log = "^0.3"
+hex = "^0.3"
rand = "^0.4"
libc = "0.2"
nix = "0.9"
rustc-serialize = "0.3.22"
-treebitmap = "^0.2"
-
-env_logger = "^0.4"
-log = "^0.3"
-
-bytes = "0.4"
-futures = "^0.1"
+pnet = "*"
+snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
+socket2 = "^0.3"
+structopt = "^0.1"
+structopt-derive = "^0.1"
+time = "*"
tokio-io = "^0.1"
tokio-core = "^0.1"
tokio-uds = "^0.1"
tokio-utun = "^0.1"
tokio-timer = "^0.1"
-
-socket2 = "^0.3"
-
-snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
-base64 = "^0.5"
-hex = "^0.3"
-time = "*"
-pnet = "*"
+treebitmap = "^0.2"