aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-02-12 23:56:38 +0000
committerJake McGinty <me@jake.su>2018-02-13 01:26:39 +0000
commit43c80f2489d429d168ec3e9c3664908971ffeac3 (patch)
treebc12f596c8a6633d9f597ecd62c090a4605e4d81 /Cargo.toml
parentconsolidate more handshake crypto (diff)
downloadwireguard-rs-43c80f2489d429d168ec3e9c3664908971ffeac3.tar.xz
wireguard-rs-43c80f2489d429d168ec3e9c3664908971ffeac3.zip
verify mac1 for handshake messages
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 4 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1ebec71..aebec33 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,6 +6,9 @@ license = "GPL-3.0"
repository = "https://git.zx2c4.com/wireguard-rs/"
description = "Userspace implementation of WireGuard, a fast, modern and secure VPN tunnel."
+[profile.release]
+debug = true
+
[dependencies]
base64 = "^0.5"
blake2-rfc = "0.2"
@@ -34,3 +37,4 @@ tokio-uds = "^0.1"
tokio-utun = "^0.1"
tokio-timer = "^0.1"
treebitmap = "^0.2"
+x25519-dalek = "0.1.0"