aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-05-15 18:33:17 -0700
committerJake McGinty <me@jake.su>2018-05-15 18:33:17 -0700
commit6e80f8d9f6aa6ff44979b7c61705564f33886088 (patch)
tree66e3c76cfaa47d988eab4c61d468c0d1c5d6ff75 /Cargo.toml
parentglobal: fix clippies and enable warnings in IDE (diff)
downloadwireguard-rs-6e80f8d9f6aa6ff44979b7c61705564f33886088.tar.xz
wireguard-rs-6e80f8d9f6aa6ff44979b7c61705564f33886088.zip
global: upgrade snow, x25519-dalek and related deps
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5b28e01..b4059f7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -42,7 +42,7 @@ libc = { git = "https://github.com/rust-lang/libc" }
log = "^0.4"
hex = "^0.3"
notify = "4.0.0"
-rand = "^0.4"
+rand = "0.5.0-pre.2"
nix = { git = "https://github.com/mcginty/nix", branch = "ipv6-pktinfo"}
mio = "^0.6"
pnet_packet = "^0.21"
@@ -56,7 +56,7 @@ tokio-uds = "^0.1"
tokio-utun = "^0.1.10"
tokio-signal = "^0.1"
treebitmap = "^0.2"
-x25519-dalek = { git = "https://github.com/mcginty/x25519-dalek" }
+x25519-dalek = "0.2"
daemonize = { git = "https://github.com/mcginty/daemonize", optional = true }
chrono = { version = "^0.4", optional = true }