aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-06-01 21:37:09 -0500
committerJake McGinty <me@jake.su>2018-06-01 21:38:03 -0500
commit89e80e0c3c7f505944d5730136d210b436285694 (patch)
tree1a1935623802e9ccd2f89e134df382e9f5c25d2a /Cargo.toml
parentencryption wip (diff)
downloadwireguard-rs-89e80e0c3c7f505944d5730136d210b436285694.tar.xz
wireguard-rs-89e80e0c3c7f505944d5730136d210b436285694.zip
crossbeam crypto pool
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1e35080..06d7852 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -34,10 +34,10 @@ blake2-rfc = "0.2"
byteorder = "^1.2"
bytes = "0.4"
chacha20-poly1305-aead = "^0.1"
+crossbeam-channel = "0.1"
derive_deref = "^1.0"
failure = "^0.1"
futures = "^0.1"
-futures-cpupool = "^0.1"
lazy_static = "^1"
libc = { git = "https://github.com/rust-lang/libc" }
log = "^0.4"
@@ -46,6 +46,7 @@ notify = "^4.0"
rand = "0.5.0-pre.2"
nix = { git = "https://github.com/mcginty/nix", branch = "ipv6-pktinfo" }
mio = "^0.6"
+num_cpus = "1.0"
pnet_packet = "^0.21"
snow = { git = "https://github.com/mcginty/snow", branch = "wireguard" }
socket2 = "^0.3"