aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-03-08 15:04:44 +0000
committerJake McGinty <me@jake.su>2018-03-08 18:44:18 +0000
commit8d006ede051b7a7990fd6870a4c733fc744e79e6 (patch)
tree249a407caee516ec9da7040a2b75b16cc5bbde72 /Cargo.toml
parentdep: fixed linux tun in mio-utun (diff)
downloadwireguard-rs-8d006ede051b7a7990fd6870a4c733fc744e79e6.tar.xz
wireguard-rs-8d006ede051b7a7990fd6870a4c733fc744e79e6.zip
config: support fwmark
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 2 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5c8ba3a..f61f898 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -41,7 +41,7 @@ log = "^0.4"
hex = "^0.3"
notify = "4.0.0"
rand = "^0.4"
-nix = "^0.10"
+nix = { git = "https://github.com/mcginty/nix", branch = "so_mark"} # TODO waiting on https://github.com/nix-rust/nix/pull/873
mio = "^0.6"
pnet_packet = "^0.20"
snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
@@ -50,7 +50,7 @@ subtle = "^0.5"
tokio-io = "^0.1"
tokio-core = "^0.1"
tokio-uds = "^0.1"
-tokio-utun = "^0.1"
+tokio-utun = "^0.1.9"
tokio-timer = "^0.1"
tokio-signal = "^0.1"
treebitmap = "^0.2"