aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-03-01 21:40:27 +0000
committerJake McGinty <me@jake.su>2018-03-04 01:23:43 +0000
commita19f0aaf515c78d53dec05fd3b3c6a2f38621508 (patch)
tree73668514662ce09bb3d69b2b1389e8388a265286 /Cargo.toml
parentudp: switch to own tokio UdpSocket implementation for performance reasons (diff)
downloadwireguard-rs-a19f0aaf515c78d53dec05fd3b3c6a2f38621508.tar.xz
wireguard-rs-a19f0aaf515c78d53dec05fd3b3c6a2f38621508.zip
udp: enable SO_REUSEPORT to start getting clever
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 36aa823..5c8ba3a 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -45,7 +45,7 @@ nix = "^0.10"
mio = "^0.6"
pnet_packet = "^0.20"
snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
-socket2 = "^0.3"
+socket2 = { version = "^0.3", features = ["reuseport"] }
subtle = "^0.5"
tokio-io = "^0.1"
tokio-core = "^0.1"