aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-05-01 20:56:07 -0700
committerJake McGinty <me@jake.su>2018-05-01 20:56:07 -0700
commita686e04ceb04c86eee258eacba6bb09d6c386118 (patch)
tree753ce54137574cee3d126239c06d7eb92f72b7b4 /Cargo.toml
parentglobal: update snow dependency (and others while I'm at it) (diff)
downloadwireguard-rs-a686e04ceb04c86eee258eacba6bb09d6c386118.tar.xz
wireguard-rs-a686e04ceb04c86eee258eacba6bb09d6c386118.zip
noise: use my updated fork of x25519-dalek to reduce old deps
This also provides a 15% performance boost for handshakes. Pending merge in the official repository.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2946d1c..5b28e01 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -56,7 +56,7 @@ tokio-uds = "^0.1"
tokio-utun = "^0.1.10"
tokio-signal = "^0.1"
treebitmap = "^0.2"
-x25519-dalek = "^0.1"
+x25519-dalek = { git = "https://github.com/mcginty/x25519-dalek" }
daemonize = { git = "https://github.com/mcginty/daemonize", optional = true }
chrono = { version = "^0.4", optional = true }