aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-04-24 21:59:43 -0700
committerJake McGinty <me@jake.su>2018-04-24 21:59:45 -0700
commita6f923d220fa873311a732866c148afc6ea592f2 (patch)
treeac067c4def2f5e3ac7b65826a0e308fbe5ca685b /Cargo.toml
parenttests: more informative error bubbling for netns failures (diff)
downloadwireguard-rs-a6f923d220fa873311a732866c148afc6ea592f2.tar.xz
wireguard-rs-a6f923d220fa873311a732866c148afc6ea592f2.zip
timer: use tokio-timer 0.2 and make timers cancelable
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml2
1 files changed, 1 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index eb62b15..c070568 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -49,11 +49,11 @@ pnet_packet = "^0.21"
snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
socket2 = "^0.3"
subtle = "^0.5"
+tokio = "^0.1.5"
tokio-io = "^0.1"
tokio-core = "^0.1"
tokio-uds = "^0.1"
tokio-utun = "^0.1.10"
-tokio-timer = "^0.1"
tokio-signal = "^0.1"
treebitmap = "^0.2"
x25519-dalek = "^0.1"