aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJake McGinty <me@jake.su>2018-02-17 20:12:29 +0000
committerJake McGinty <me@jake.su>2018-02-17 20:12:29 +0000
commit6a976a4c1636cf2a93224f472593c8c041e4e71d (patch)
tree335033ea5da24b7afbe421da37c9ca074c7ad201 /Cargo.toml
parentfix criterion bench (diff)
downloadwireguard-rs-6a976a4c1636cf2a93224f472593c8c041e4e71d.tar.xz
wireguard-rs-6a976a4c1636cf2a93224f472593c8c041e4e71d.zip
cookie module
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml8
1 files changed, 4 insertions, 4 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6f4fa82..58115b2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -29,6 +29,7 @@ base64 = "^0.5"
blake2-rfc = "0.2"
byteorder = "^1.2"
bytes = "0.4"
+chacha20-poly1305-aead = "^0.1"
daemonize = "0.2"
env_logger = "^0.4"
failure = "^0.1"
@@ -37,8 +38,7 @@ lazy_static = "^1"
log = "^0.3"
hex = "^0.3"
rand = "^0.4"
-libc = "0.2"
-nix = "0.9"
+nix = "^0.10"
rustc-serialize = "0.3.22"
pnet = "*"
snow = { git = "https://github.com/mcginty/snow", features = ["ring-accelerated"], branch = "wireguard" }
@@ -46,11 +46,11 @@ socket2 = "^0.3"
structopt = "^0.1"
structopt-derive = "^0.1"
subtle = "^0.5"
-time = "*"
+time = "^0.1"
tokio-io = "^0.1"
tokio-core = "^0.1"
tokio-uds = "^0.1"
tokio-utun = "^0.1"
tokio-timer = "^0.1"
treebitmap = "^0.2"
-x25519-dalek = "0.1.0"
+x25519-dalek = "^0.1"