summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2020-01-26 13:51:59 +0100
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2020-01-26 13:54:22 +0100
commit2015663706fbe15ed1ac443a31de86b3e6c643c7 (patch)
tree8dd71fd5878e9b8e598353e7b159beb8c78c8c6d /Cargo.toml
parentFixed bind6 also binding on IPv4 (diff)
downloadwireguard-rs-2015663706fbe15ed1ac443a31de86b3e6c643c7.tar.xz
wireguard-rs-2015663706fbe15ed1ac443a31de86b3e6c643c7.zip
Restructure of public key -> peer state
Restructured the mapping of public keys to peer state in the project. The handshake device is now generic over an opaque type, which enables it to be the sole place where public keys are mapped to the peer states. This gets rid of the "peer" map in the WireGuard devices and avoids having to include the public key in the handshake peer state.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml15
1 files changed, 8 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1055db7..91cac08 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,13 +1,12 @@
[package]
name = "wireguard-rs"
-version = "0.1.0"
+version = "0.1.1"
authors = ["Mathias Hall-Andersen <mathias@hall-andersen.dk>"]
edition = "2018"
[dependencies]
hex = "0.3"
-spin = "0.5.0"
-rand = "0.6.5"
+spin = "0.5.2"
blake2 = "0.8"
log = { version = "0.4", features = ["max_level_trace", "release_max_level_info"] }
hmac = "0.7.1"
@@ -19,8 +18,10 @@ arraydeque = "0.4.5"
treebitmap = "^0.4"
hjul = "0.2.1"
ring = "0.16.7"
-chacha20poly1305 = "^0.1"
-aead = "^0.1.1"
+rand = "^0.7"
+rand_core = "^0.5"
+chacha20poly1305 = "^0.3"
+aead = "^0.2"
clear_on_drop = "0.2.3"
env_logger = "0.6"
num_cpus = "^1.10"
@@ -32,7 +33,7 @@ cpuprofiler = { version = "*", optional = true }
libc = "0.2"
[dependencies.x25519-dalek]
-version = "^0.5"
+version = "^0.6"
[dependencies.subtle]
version = "2.1"
@@ -46,4 +47,4 @@ start_up = []
pnet = "^0.22"
proptest = "0.9.4"
rand_chacha = "0.2.1"
-rand_core = "0.5"
+