aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2019-08-30 19:46:00 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2019-08-30 19:46:00 +0200
commit0520b28ac2d1918db4bd19d551448b8471cbb65a (patch)
tree36d17f524beb400ae89069be354738c22d67d00d /Cargo.toml
parentJoin with worker threads on device drop (diff)
downloadwireguard-rs-0520b28ac2d1918db4bd19d551448b8471cbb65a.tar.xz
wireguard-rs-0520b28ac2d1918db4bd19d551448b8471cbb65a.zip
Move to RustCrypto AEAD crate for handshake
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6f285bb..5a9464d 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,7 +15,6 @@ generic-array = "0.12.3"
zerocopy = "0.2.7"
byteorder = "1.3.1"
digest = "0.8.0"
-sodiumoxide = "0.2.2"
lazy_static = "^1.3"
tokio = "0.1.22"
futures = "0.1.28"
@@ -24,6 +23,8 @@ treebitmap = "^0.4"
crossbeam-deque = "0.7"
hjul = "0.1.2"
ring = "0.16.7"
+chacha20poly1305 = "^0.1"
+aead = "^0.1.1"
[dependencies.x25519-dalek]
version = "^0.5"