aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2020-05-22 18:01:15 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2020-05-22 18:01:15 +0200
commit16ede0f37da6050d3037cd85eb1055f239cef7b8 (patch)
treeec6172fdd1c2c3d97bedcbcc93bce5cd34049b9b /Cargo.toml
parentElimited Daemonize dependency (diff)
downloadwireguard-rs-16ede0f37da6050d3037cd85eb1055f239cef7b8.tar.xz
wireguard-rs-16ede0f37da6050d3037cd85eb1055f239cef7b8.zip
Enable wireguard-rs to build on stable.
WireGuard Rust targets the latest nightly compiler, primarily for security and speed reasons. The recommended way to build WireGuard Rust is still with latest nightly.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml9
1 files changed, 6 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index c626761..625e830 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -15,8 +15,7 @@ zerocopy = "0.3"
byteorder = "1.3"
digest = "0.8.1"
arraydeque = "0.4.5"
-treebitmap = { git = "https://github.com/JakubOnderka/treebitmap" }
-hjul = "0.2.1"
+hjul = "0.2.2"
ring = "0.16.7"
rand = "^0.7"
rand_core = "^0.5"
@@ -28,6 +27,10 @@ num_cpus = "^1.10"
crossbeam-channel = "0.4"
cpuprofiler = { version = "*", optional = true }
+[dependencies.treebitmap]
+git = "https://github.com/JakubOnderka/treebitmap"
+rev = "207c371a501780a94a8cd375fe15f877b110d9e2"
+
[target.'cfg(unix)'.dependencies]
libc = "0.2"
@@ -36,7 +39,7 @@ version = "^0.6"
[dependencies.subtle]
version = "2.1"
-features = ["nightly"]
+#features = ["nightly"]
[features]
profiler = ["cpuprofiler"]