aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2019-07-26 15:46:24 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2019-07-26 15:46:24 +0200
commit5efb31817180d08c4ffdff616ab80e5172276c29 (patch)
tree1ccefd86684146dabcf5f4785286360f9fbc8c87 /Cargo.toml
parentFormatting (diff)
downloadwireguard-rs-5efb31817180d08c4ffdff616ab80e5172276c29.tar.xz
wireguard-rs-5efb31817180d08c4ffdff616ab80e5172276c29.zip
Move parser code to zerocopy
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml4
1 files changed, 3 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 2ccb719..af24051 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -3,7 +3,7 @@ name = "wg-handshake"
version = "0.1.0"
authors = ["Mathias Hall-Andersen <mathias@hall-andersen.dk>"]
edition = "2018"
-license = "GPL-3.0"
+license = "MIT"
[dependencies]
hex = "0.3"
@@ -13,6 +13,8 @@ blake2 = "0.8.0"
hmac = "0.7.1"
rust-crypto = "^0.2"
generic-array = "0.12.3"
+zerocopy = "0.2.7"
+byteorder = "1.3.1"
[dependencies.x25519-dalek]
version = "^0.5"