aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorMathias Hall-Andersen <mathias@hall-andersen.dk>2019-09-02 23:32:07 +0200
committerMathias Hall-Andersen <mathias@hall-andersen.dk>2019-09-02 23:32:07 +0200
commitf55014ef8ff7308d37be9c92f41b9ccf809c719d (patch)
tree0a8ea562dd872b1a5a0a2271256bd1b6d6d5d731 /Cargo.toml
parentReconsider inorder queueing (diff)
downloadwireguard-rs-f55014ef8ff7308d37be9c92f41b9ccf809c719d.tar.xz
wireguard-rs-f55014ef8ff7308d37be9c92f41b9ccf809c719d.zip
Wake workers when submitting work
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 2 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 05b44b0..620c97f 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -18,7 +18,7 @@ digest = "0.8.0"
lazy_static = "^1.3"
tokio = "0.1.22"
futures = "0.1.28"
-arraydeque = "^0.4"
+arraydeque = "0.4.5"
treebitmap = "^0.4"
crossbeam-deque = "0.7"
hjul = "0.1.2"
@@ -26,6 +26,7 @@ ring = "0.16.7"
chacha20poly1305 = "^0.1"
aead = "^0.1.1"
clear_on_drop = "0.2.3"
+parking_lot = "^0.9"
[dependencies.x25519-dalek]
version = "^0.5"