aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--Cargo.toml16
1 files changed, 8 insertions, 8 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1298a28..91cac08 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,14 +1,12 @@
[package]
name = "wireguard-rs"
-version = "0.1.0"
+version = "0.1.1"
authors = ["Mathias Hall-Andersen <mathias@hall-andersen.dk>"]
edition = "2018"
-license = "MIT"
[dependencies]
hex = "0.3"
-spin = "0.5.0"
-rand = "0.6.5"
+spin = "0.5.2"
blake2 = "0.8"
log = { version = "0.4", features = ["max_level_trace", "release_max_level_info"] }
hmac = "0.7.1"
@@ -20,8 +18,10 @@ arraydeque = "0.4.5"
treebitmap = "^0.4"
hjul = "0.2.1"
ring = "0.16.7"
-chacha20poly1305 = "^0.1"
-aead = "^0.1.1"
+rand = "^0.7"
+rand_core = "^0.5"
+chacha20poly1305 = "^0.3"
+aead = "^0.2"
clear_on_drop = "0.2.3"
env_logger = "0.6"
num_cpus = "^1.10"
@@ -33,7 +33,7 @@ cpuprofiler = { version = "*", optional = true }
libc = "0.2"
[dependencies.x25519-dalek]
-version = "^0.5"
+version = "^0.6"
[dependencies.subtle]
version = "2.1"
@@ -47,4 +47,4 @@ start_up = []
pnet = "^0.22"
proptest = "0.9.4"
rand_chacha = "0.2.1"
-rand_core = "0.5"
+