aboutsummaryrefslogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-10-15 01:22:57 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-10-15 17:02:36 +0200
commita934cafcf928b9e8cf2aaf749dca68fa6fa689d7 (patch)
tree25c8d36cbcbff88eedfff9d7fef9169fb77c8779 /.travis.yml
parentChildWatcherTestCase: python3.8 compat (diff)
downloadgentoo-portage-a934cafcf928b9e8cf2aaf749dca68fa6fa689d7.tar.xz
gentoo-portage-a934cafcf928b9e8cf2aaf749dca68fa6fa689d7.zip
Add python-3.8, drop python-3.4 from testing
Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml15
1 files changed, 5 insertions, 10 deletions
diff --git a/.travis.yml b/.travis.yml
index ab0b8d30425..b1b4bf26bb3 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -1,18 +1,12 @@
language: python
python:
- 2.7
- - 3.4
- 3.5
- 3.6
+ - 3.7
+ - 3.8-dev
- pypy
-# See https://github.com/travis-ci/travis-ci/issues/9815
-matrix:
- include:
- - python: 3.7
- dist: xenial
- sudo: required
-
# command to install dependencies
install:
- pip install tox
@@ -21,8 +15,9 @@ script:
- printf "[build_ext]\nportage-ext-modules=true" >> setup.cfg
- ./setup.py test
- ./setup.py install --root=/tmp/install-root
- - if [[ ${TRAVIS_PYTHON_VERSION} == ?.? ]]; then
- tox -e py${TRAVIS_PYTHON_VERSION/./};
+ - if [[ ${TRAVIS_PYTHON_VERSION/-dev/} == ?.? ]]; then
+ TOX_PYTHON_VERSION=${TRAVIS_PYTHON_VERSION/-dev/};
+ tox -e py${TOX_PYTHON_VERSION/./};
else
tox -e ${TRAVIS_PYTHON_VERSION};
fi