aboutsummaryrefslogtreecommitdiffstats
path: root/.travis.yml
diff options
context:
space:
mode:
authorBrian Dolbec <dolsen@gentoo.org>2016-05-14 16:39:39 -0700
committerBrian Dolbec <dolsen@gentoo.org>2016-05-15 11:17:11 -0700
commite004e7a3be9420790481630ffd9671d2a57a72ae (patch)
tree9c346964297d55fdb41caf5802dc662645708552 /.travis.yml
parentrepoman: Fix the repoman/runtests script to run from it's current location (diff)
downloadgentoo-portage-e004e7a3be9420790481630ffd9671d2a57a72ae.tar.xz
gentoo-portage-e004e7a3be9420790481630ffd9671d2a57a72ae.zip
.travis.yml: Update for the new repoman sub-structure
Fix the metadata.xsd file copy to find it in the new repoman namespace Add repoman test suite Add lxml dependency
Diffstat (limited to '.travis.yml')
-rw-r--r--.travis.yml13
1 files changed, 12 insertions, 1 deletions
diff --git a/.travis.yml b/.travis.yml
index 5213feed1a7..53e60bcf6bb 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -5,11 +5,22 @@ python:
- 3.4
- 3.5
- pypy
+
+# command to install dependencies
+install: "pip install lxml"
+
script:
- ./setup.py test
- ./setup.py install --root=/tmp/install-root
# prevent repoman tests from trying to fetch metadata.xsd
- mkdir -p /tmp/install-root/usr/lib/portage/cnf
- - cp cnf/metadata.xsd /tmp/install-root/usr/lib/portage/cnf/
+ - cp repoman/cnf/metadata.xsd /tmp/install-root/usr/lib/portage/cnf/
- sudo rsync -a /tmp/install-root/. /
- python -b -Wd -m portage.tests.runTests
+ # repoman test block
+ - cd repoman
+ - ./setup.py test
+ - ./setup.py install --root=/tmp/install-root
+ - cd ..
+ - sudo rsync -a /tmp/install-root/. /
+ - python -b -Wd -m repoman.tests.runTests