aboutsummaryrefslogtreecommitdiffstats
path: root/DEVELOPING
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2022-09-22 14:40:29 -0400
committerMike Gilbert <floppym@gentoo.org>2022-09-24 12:27:57 -0400
commit72f299d34cd97d70f3182ad252a2f5d62f0d7cef (patch)
treeb057fa54193c9329c72aef89eeaf116ec650183f /DEVELOPING
parentsetup.py: release 3.0.37 (diff)
downloadgentoo-portage-72f299d34cd97d70f3182ad252a2f5d62f0d7cef.tar.xz
gentoo-portage-72f299d34cd97d70f3182ad252a2f5d62f0d7cef.zip
DEVELOPING: differentiate spaces/tabs in Python/Bash files
Closes: https://github.com/gentoo/portage/pull/905 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'DEVELOPING')
-rw-r--r--DEVELOPING5
1 files changed, 3 insertions, 2 deletions
diff --git a/DEVELOPING b/DEVELOPING
index 38e6032d6d6a..3a97f1aa0f30 100644
--- a/DEVELOPING
+++ b/DEVELOPING
@@ -21,12 +21,13 @@ with Python itself, must be optionally enabled by runtime detection.
Tabs
----
-We comply with PEP 8 so we now use spaces.
+We comply with PEP 8 so we now use spaces in Python source files.
+We use tabs in Bash files for consistency with ebuild code.
Line-Wrapping
-------------
-Please use Black for formatting.
+Please use Black for formatting of Python source files.
Lines should typically not be longer than 80 characters; if they are, an
attempt should be made to wrap them. Move code to the line below and