aboutsummaryrefslogtreecommitdiffstats
path: root/DEVELOPING
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-04 05:39:08 +0000
committerSam James <sam@gentoo.org>2023-03-04 05:39:08 +0000
commitc7b4f553a3e19a4ee3043a737fa8f0e55c516bbd (patch)
treeee6ee51622822bbc6bb85964efe00e2c8d797801 /DEVELOPING
parentNEWS: fix oldish typo (diff)
downloadgentoo-portage-c7b4f553a3e19a4ee3043a737fa8f0e55c516bbd.tar.xz
gentoo-portage-c7b4f553a3e19a4ee3043a737fa8f0e55c516bbd.zip
DEVELOPING: update release process
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'DEVELOPING')
-rw-r--r--DEVELOPING42
1 files changed, 28 insertions, 14 deletions
diff --git a/DEVELOPING b/DEVELOPING
index 3a97f1aa0f30..2f05d49b5cfa 100644
--- a/DEVELOPING
+++ b/DEVELOPING
@@ -209,33 +209,47 @@ For a more detailed explanation (and rationalisation) of these rules:
Releases
--------
-Before starting: CI MUST BE GREEN!
+0. Before starting: CI MUST BE GREEN!
-First update:
-- NEWS (for both new version & release date)
-- setup.py
+1. Repository mangling:
+ - Update NEWS (for both new version & release date)
+ - Update setup.py
and commit.
-Second create a git tag for this release:
- git tag portage-3.0.30
+2. Create a git tag for this release:
+ git tag -a -s portage-3.0.30
-Create the tarball and run the tests: ./runtests
-(see PYTHON_SUPPORTED_VERSIONS in runtests).
+3. Create the tarball and run the tests: ./runtests
+ (see PYTHON_SUPPORTED_VERSIONS in runtests).
-Version bump the ebuild locally (don't push) and verify it can re-install itself:
- emerge --oneshot portage
- emerge --oneshot portage # this is using the new Portage
+4. Version bump the ebuild locally (don't push) and verify it can re-install itself:
+ emerge --oneshot sys-apps/portage
+ emerge --oneshot sys-apps/portage # this is using the new Portage
-Publish the results (no going back now):
+5. Publish the results (no going back now):
- Push the new git tag
- Upload the tarball
- Commit the new ebuild version and tag the tracker bug for the commit
-Create the release for pypi and upload it there:
+6. Create the release for pypi and upload it there:
- python -m venv .venv
- . .venv/bin/activate
- pip install wheel twine
- python setup.py bdist_wheel sdist
- twine upload dist/<filenames>
-Close the bugs blocking the tracker bug for this release.
+7. Bugzilla wrangling:
+ - Close the bugs blocked by the tracker bug for this release and
+ the tracker itself.
+
+ - File a new bug in Portage Development > Core named
+ "[TRACKER] sys-apps/portage-${NEW_VERSION}"
+ with the 'Tracker' Bugzilla Keyword and the following text:
+ """
+ Tracks bugs fixed in this release.
+
+ 'Depends on' now means 'we want to fix this before release'
+ 'Blocks' means 'fixed in this release'
+ """
+
+8. Done! Congratulations!