aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVadim Yanitskiy <vyanitskiy@sysmocom.de>2021-01-14 18:55:26 +0100
committerVadim Yanitskiy <vyanitskiy@sysmocom.de>2021-01-14 18:57:52 +0100
commit2ecb71bcd4e01253e09fc330597a90a109ef2e0a (patch)
treeca9ec47830c32dd6f2901a83793ef6c49f206807 /configure.ac
parentctrl: ports.h: Add OSMO_CTRL_PORT_BSC_NEIGH (diff)
downloadlibosmocore-2ecb71bcd4e01253e09fc330597a90a109ef2e0a.tar.xz
libosmocore-2ecb71bcd4e01253e09fc330597a90a109ef2e0a.zip
fixup: configure.ac: fix: do not define HAVE_NEON unconditionally
Instead of removing AC_DEFINE(), I should have used AS_IF(). Change-Id: I20e256bd6fdb0256c95ab7073e07b7437af6a12f Fixes: I761a7afaeda9d232ac26edff47949e911f8f1f0c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c062e5fe..32ea7ca7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -424,6 +424,9 @@ AC_ARG_ENABLE(neon,
[Enable ARM NEON instructions support [default=no]]
)],
[neon=$enableval], [neon="no"])
+AS_IF([test "x$neon" = "xyes"], [
+ AC_DEFINE([HAVE_NEON],, [Support ARM NEON instructions])
+])
AC_MSG_CHECKING([whether to enable ARM NEON instructions support])
AC_MSG_RESULT([$neon])
AM_CONDITIONAL(HAVE_NEON, [test "x$neon" != "xno"])