aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wild <ewild@sysmocom.de>2021-11-26 21:09:01 +0100
committerlaforge <laforge@osmocom.org>2021-12-09 15:25:53 +0000
commit63e1b2b024cd7b0b4f7965e244229e3fb9ea17a0 (patch)
tree6a21500d3c6aed49e76bb2ec1966705d0a76b676 /configure.ac
parentVTY: enable talloc introspection for OTC_GLOBAL (diff)
downloadlibosmocore-63e1b2b024cd7b0b4f7965e244229e3fb9ea17a0.tar.xz
libosmocore-63e1b2b024cd7b0b4f7965e244229e3fb9ea17a0.zip
logging: make LIBOSMOCORE_NO_LOGGING work as expected
The macro introduced in d02090bba538158c36fd838d4e50c47e40f11449 was not enough: the actual logging macros are being used, i.e. by the fsm, so wrap those as well, and provide a flag to disable this at build time. Change-Id: Ia4c78abe5f198139f96ffa289998855be2477585
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b36bd6fa..a69f793f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -366,6 +366,17 @@ then
AC_DEFINE([PANIC_INFLOOP],[1],[Use infinite loop on panic rather than fprintf/abort])
fi
+AC_ARG_ENABLE(log_macros,
+ [AS_HELP_STRING(
+ [--disable-log-macros],
+ [Disable logging macros that are also used internally to print information]
+ )],
+ [log_macros="yes"], [log_macros="no"])
+if test x"$log_macros" == x"yes"
+then
+ AC_DEFINE([LIBOSMOCORE_NO_LOGGING],[1],[Disable logging macros])
+fi
+
AC_ARG_ENABLE(sanitize,
[AS_HELP_STRING(
[--enable-sanitize],