aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2020-04-17 19:20:01 +0200
committerHarald Welte <laforge@osmocom.org>2020-04-18 21:16:12 +0200
commita70ac85f5bf0d9a7bc0eeae94d38bd680bea5ebb (patch)
tree4d67654c596a66d8bad0d1c180fc46c7a565bd3d /configure.ac
parentexec: Introduce osmo_system_nowait2() to allow specify a user (diff)
downloadlibosmocore-a70ac85f5bf0d9a7bc0eeae94d38bd680bea5ebb.tar.xz
libosmocore-a70ac85f5bf0d9a7bc0eeae94d38bd680bea5ebb.zip
select.c: Introduce support for signalfd
The signalfd(2) mechanism of Linux allows signals to be delivered and processed via normal file descriptor I/O. This avoids any of the usual problems about re-entrancy of signal processing, as signals can be processed from the osmocom select() loop abstraction just like any other event. Change-Id: If8d89dd1f6989e1cd9b9367fad954d65f91ada30
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 92457f16..352648b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -62,7 +62,7 @@ AC_SUBST(LTLDFLAGS_OSMOCTRL)
dnl checks for header files
AC_HEADER_STDC
-AC_CHECK_HEADERS(execinfo.h sys/select.h sys/socket.h sys/timerfd.h syslog.h ctype.h netinet/tcp.h netinet/in.h)
+AC_CHECK_HEADERS(execinfo.h sys/select.h sys/socket.h sys/signalfd.h sys/timerfd.h syslog.h ctype.h netinet/tcp.h netinet/in.h)
# for src/conv.c
AC_FUNC_ALLOCA
AC_SEARCH_LIBS([dlopen], [dl dld], [LIBRARY_DLOPEN="$LIBS";LIBS=""])