aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2021-12-24 11:31:12 +0100
committerHarald Welte <laforge@osmocom.org>2021-12-24 11:34:18 +0100
commitc809f4e494f988de8819d0efc72cad14f5a69ec9 (patch)
treeac969652ddfa301f3828d9d5460dadf62528eaac /configure.ac
parentselect: gather statistics for TCP connections (diff)
downloadlibosmocore-c809f4e494f988de8819d0efc72cad14f5a69ec9.tar.xz
libosmocore-c809f4e494f988de8819d0efc72cad14f5a69ec9.zip
tcp_stats: fix compilation on CentOS 7
This is to fix the following compile error on CentOS 7: [ 74s] stats_tcp.c: In function 'fill_stats': [ 74s] stats_tcp.c:138:15: error: 'struct tcp_info' has no member named 'tcpi_notsent_bytes' [ 74s] tcp_info.tcpi_notsent_bytes); [ 74s] ^ Closes: OS#5374 Change-Id: Icde6651baeb0828477dbf540a02b16a1a5f91797
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8fb299b9..89615fdf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -517,6 +517,13 @@ CHECK_BUILTIN_SUPPORT([__builtin_cpu_supports],
[Runtime SIMD detection will be disabled])
dnl There are some members in struct tcp_info that might not exist on all linux versions
+AC_CHECK_MEMBER([struct tcp_info.tcpi_notsent_bytes],
+ AC_DEFINE([HAVE_TCP_INFO_TCPI_NOTSENT_BYTES],
+ [1],
+ [Define to 1 if your <linux/tcp.h> header file have the tcpi_notsent_bytes member in struct tcp_info]),
+ [],
+ [#include <linux/tcp.h>])
+
AC_CHECK_MEMBER([struct tcp_info.tcpi_rwnd_limited],
AC_DEFINE([HAVE_TCP_INFO_TCPI_RWND_LIMITED],
[1],