aboutsummaryrefslogtreecommitdiffstats
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@osmocom.org>2020-12-04 21:44:44 +0100
committerHarald Welte <laforge@osmocom.org>2020-12-05 11:39:42 +0100
commit7101ca27516e7ae1db4278bd03ee1a14f9d7fb20 (patch)
tree7aa2134537885807e572cb83a88f4ce01f4b0928 /include/Makefile.am
parentbssgp: Fix typo in BSSGP Message Type enum (diff)
downloadlibosmocore-7101ca27516e7ae1db4278bd03ee1a14f9d7fb20.tar.xz
libosmocore-7101ca27516e7ae1db4278bd03ee1a14f9d7fb20.zip
Add hlist and hashtable from Linux kernel
For more than a decade we've used the linuxlist.h for double-linked lists. Let's also add the hlist (double-linked lists with single pointer sized head, and the hashtable that builds on top of it. This reflects the versions included in Linux 5.8 with some modifications to make them build in userspace (remove RCU versions, adjust for userspace include files and types, convert to doxygen). Change-Id: I8ef73a62fe9846ce45058eb21cf999dd3eed5741
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 71171a48..f13ae76f 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -27,9 +27,12 @@ nobase_include_HEADERS = \
osmocom/core/fsm.h \
osmocom/core/gsmtap.h \
osmocom/core/gsmtap_util.h \
+ osmocom/core/hash.h \
+ osmocom/core/hashtable.h \
osmocom/core/isdnhdlc.h \
osmocom/core/linuxlist.h \
osmocom/core/linuxrbtree.h \
+ osmocom/core/log2.h \
osmocom/core/logging.h \
osmocom/core/loggingrb.h \
osmocom/core/mnl.h \