aboutsummaryrefslogtreecommitdiffstats
path: root/src/gb/Makefile.am
diff options
context:
space:
mode:
authorHarald Welte <laforge@gnumonks.org>2018-07-01 19:09:52 +0200
committerHarald Welte <laforge@gnumonks.org>2019-02-26 11:17:44 +0000
commit17a642d8ff309119532bf85f4ad95d1b049047f0 (patch)
tree759ffa3cebcb922247961fcdc32a9a6236a9bb9e /src/gb/Makefile.am
parentenlarge gsm0808 msgb headroom (diff)
downloadlibosmocore-17a642d8ff309119532bf85f4ad95d1b049047f0.tar.xz
libosmocore-17a642d8ff309119532bf85f4ad95d1b049047f0.zip
gprs_ns: Add code for SNS-SIZE and SNS-CONFIG encoding
Modern NS specifications contain a SNS (Sub Network Service) for negotiating IP/port/weight parameters of NS-over-IP links dynamically. This patch adds message encoding routines for SNS-CONFIG, SNS-SIZE and their respective acknowledgements. Related: OS#3372 Change-Id: I5c47e1c3c10deb89a7470ee2c03adfc174accc93
Diffstat (limited to 'src/gb/Makefile.am')
-rw-r--r--src/gb/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/gb/Makefile.am b/src/gb/Makefile.am
index 65b73fef..d074092e 100644
--- a/src/gb/Makefile.am
+++ b/src/gb/Makefile.am
@@ -6,7 +6,7 @@ AM_CPPFLAGS = -I$(top_srcdir)/include -I$(top_builddir)/include
AM_CFLAGS = -Wall ${GCC_FVISIBILITY_HIDDEN} -fno-strict-aliasing $(TALLOC_CFLAGS)
# FIXME: this should eventually go into a milenage/Makefile.am
-noinst_HEADERS = common_vty.h
+noinst_HEADERS = common_vty.h gb_internal.h
if ENABLE_GB
lib_LTLIBRARIES = libosmogb.la