summaryrefslogtreecommitdiffstats
path: root/dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2015-03-14 17:11:31 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2015-03-14 17:11:31 +0100
commit92b6c7e6e3217f5249d1752fe5ea06e335b540c8 (patch)
treedc59d5e9d31b1a78ac70cd1934df1f8097e8a9b0 /dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild
parentReadd manifests (diff)
downloadportage-92b6c7e6e3217f5249d1752fe5ea06e335b540c8.tar.xz
portage-92b6c7e6e3217f5249d1752fe5ea06e335b540c8.zip
Make prettier
Diffstat (limited to 'dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild')
-rw-r--r--dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild b/dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild
new file mode 100644
index 0000000..708d3f2
--- /dev/null
+++ b/dev-qt/qtdocumentation/qtdocumentation-5.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit versionator
+
+MY_PN="qt5"
+MY_PV="$(get_version_component_range 1)$(get_version_component_range 2)"
+MY_PV_MICRO="0"
+
+DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other Qt documentation tools."
+HOMEPAGE="https://www.qt.io/ https://qt-project.org/"
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+SRC_URI="http://download.qt.io/online/qtsdkrepository/linux_x64/desktop/${MY_PN}_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${PV}-${MY_PV_MICRO}${MY_PN}_docs.7z"
+
+DEPEND="app-arch/p7zip"
+
+S="${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)"
+
+src_install() {
+ rm -rf global # We remove the docs that conflict with qtcore
+
+ local target="/usr/share/doc/qt-${PV}"
+ dodir "${target}"
+ docompress -x "${target}"
+ insinto "${target}"
+ doins -r *
+}