summaryrefslogtreecommitdiffstats
path: root/net-misc
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2012-06-05 04:08:45 +0200
committerJason A. Donenfeld <Jason@zx2c4.com>2012-06-05 04:08:45 +0200
commit6497bab4b43a1f0b052ed3eb6742cffc1bf8c87e (patch)
tree03460f3a10d645c64e0cca150793dedf532d64da /net-misc
parentUse path for fallback. (diff)
downloadportage-6497bab4b43a1f0b052ed3eb6742cffc1bf8c87e.tar.xz
portage-6497bab4b43a1f0b052ed3eb6742cffc1bf8c87e.zip
Add telnet honeypot ebuild.
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/telnet-password-honeypot/Manifest1
-rw-r--r--net-misc/telnet-password-honeypot/telnet-password-honeypot-9999.ebuild16
2 files changed, 17 insertions, 0 deletions
diff --git a/net-misc/telnet-password-honeypot/Manifest b/net-misc/telnet-password-honeypot/Manifest
new file mode 100644
index 0000000..22e3263
--- /dev/null
+++ b/net-misc/telnet-password-honeypot/Manifest
@@ -0,0 +1 @@
+EBUILD telnet-password-honeypot-9999.ebuild 352 RMD160 a99b6efd063cb55b99b95961681f52904076429c SHA1 8562fe175b21a1fb6814eacf40b717f93e1a769a SHA256 3d96067500f0e67f7a28a9578d7ad9897ce68faf51e61391e318f8f710363a83
diff --git a/net-misc/telnet-password-honeypot/telnet-password-honeypot-9999.ebuild b/net-misc/telnet-password-honeypot/telnet-password-honeypot-9999.ebuild
new file mode 100644
index 0000000..a81532b
--- /dev/null
+++ b/net-misc/telnet-password-honeypot/telnet-password-honeypot-9999.ebuild
@@ -0,0 +1,16 @@
+# Copyright 2012 Jason A. Donenfeld <Jason@zx2c4.com>
+
+inherit git-2
+
+DESCRIPTION="A password honeypot for telnet."
+HOMEPAGE="http://code.kryo.se/iodine/"
+SRC_URI=""
+EGIT_REPO_URI="http://git.zx2c4.com/telnet-password-honeypot"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_install() {
+ dobin honeypot
+ newinitd honeypot.initd honeypot
+ keepdir /var/empty
+}