summaryrefslogtreecommitdiffstats
path: root/net-misc
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2015-02-10 21:47:34 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2015-02-10 21:47:34 +0100
commite521a42f7b4fdac936c6de00768c9aa8309df0f6 (patch)
tree5f75459be52ea93a041d2740b2a5573315321171 /net-misc
parentAdd new gnu portable threads library. (diff)
downloadportage-e521a42f7b4fdac936c6de00768c9aa8309df0f6.tar.xz
portage-e521a42f7b4fdac936c6de00768c9aa8309df0f6.zip
Updates
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cudaminer/cudaminer-9999.ebuild26
-rw-r--r--net-misc/iodine/ChangeLog27
-rw-r--r--net-misc/iodine/Manifest9
-rw-r--r--net-misc/iodine/files/iodine-0.5.2-Makefile.patch38
-rw-r--r--net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch17
-rw-r--r--net-misc/iodine/files/iodine-0.6.0_rc1-ifconfig-path.patch21
-rw-r--r--net-misc/iodine/files/iodined.conf44
-rw-r--r--net-misc/iodine/files/iodined.init62
-rw-r--r--net-misc/iodine/iodine-0.6.0_rc1-r1.ebuild45
-rw-r--r--net-misc/iodine/metadata.xml13
10 files changed, 26 insertions, 276 deletions
diff --git a/net-misc/cudaminer/cudaminer-9999.ebuild b/net-misc/cudaminer/cudaminer-9999.ebuild
new file mode 100644
index 0000000..4e55cd0
--- /dev/null
+++ b/net-misc/cudaminer/cudaminer-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit git-2
+
+DESCRIPTION="CUDA accelerated litecoin mining application based on pooler's CPU miner"
+HOMEPAGE="https://github.com/cbuchner1/CudaMiner"
+SRC_URI=""
+EGIT_REPO_URI="https://github.com/cbuchner1/CudaMiner.git"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="<dev-util/nvidia-cuda-toolkit-5.5"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ export CFLAGS=""
+ export LDFLAGS="-L/opt/cuda/lib64"
+ econf
+}
diff --git a/net-misc/iodine/ChangeLog b/net-misc/iodine/ChangeLog
deleted file mode 100644
index 75d8117..0000000
--- a/net-misc/iodine/ChangeLog
+++ /dev/null
@@ -1,27 +0,0 @@
-# ChangeLog for net-misc/iodine
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/ChangeLog,v 1.4 2011/11/05 22:38:07 robbat2 Exp $
-
- 05 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> iodine-0.5.2.ebuild,
- iodine-0.6.0_rc1.ebuild:
- Fix CONFIG_CHECK usage to be non-fatal, this package does not build kernel
- modules. Verified good build with no kernel sources or kernel config
- available.
-
- 07 Jun 2011; Víctor Ostorga <vostorga@gentoo.org> iodine-0.6.0_rc1.ebuild,
- +files/iodine-0.6.0_rc1-TestMessage.patch:
- Fixing message given to user when executing test phase, bug #370091
-
-*iodine-0.6.0_rc1 (16 Mar 2010)
-
- 16 Mar 2010; Víctor Ostorga <vostorga@gentoo.org>
- +iodine-0.6.0_rc1.ebuild:
- Version bump to 0.6.0-rc1, bug #309697
-
-*iodine-0.5.2 (26 Sep 2009)
-
- 26 Sep 2009; Víctor Ostorga <vostorga@gentoo.org> +iodine-0.5.2.ebuild,
- +files/iodine-0.5.2-Makefile.patch, +files/iodined.conf,
- +files/iodined.init, +metadata.xml:
- Initial commit, ebuild thanks to Erik Ekman bug 173038
-
diff --git a/net-misc/iodine/Manifest b/net-misc/iodine/Manifest
deleted file mode 100644
index f0ebd91..0000000
--- a/net-misc/iodine/Manifest
+++ /dev/null
@@ -1,9 +0,0 @@
-AUX iodine-0.5.2-Makefile.patch 1160 RMD160 312892d2ad82456fc827b14ab72d70ab028c8d3a SHA1 924af0d6a0eba19068a295fa9ddd91b53743de5a SHA256 1fce3a95bfb403b809cf1ea5c4c2b707382970697f608633620570456f6574dd
-AUX iodine-0.6.0_rc1-TestMessage.patch 660 RMD160 fb22538caf1ba57de7269617e2f7deb40e92a700 SHA1 e351f779f4da3650fe1ee00d71b1e537259e2470 SHA256 a14cbb88a2f65b4ffc22b2d884f875ba0ebfd2b0c7ae0f33cb8a1dc9389f1569
-AUX iodine-0.6.0_rc1-ifconfig-path.patch 627 RMD160 13961f333ddda7ac0755cf7ff9f26aaeba7ede85 SHA1 8299d391374eef6746a68eb3e3a5b122246d26f1 SHA256 83fe5ba43eb5407731355e44d0d0c1688ac075d7f1832e3bf0aae2f192df9c19
-AUX iodined.conf 1547 RMD160 ad496ac03a3ace69556c098e7269d6152268ed94 SHA1 9e819aea6042a272b0ab589b37d2140fdbde2615 SHA256 01860664e8121308d0efb17258374a8a248293c4ed375a5b6f50d6568ceb8750
-AUX iodined.init 1534 RMD160 1160cdb68d4d0f535e11c7d9bb9a064d5cac8e78 SHA1 406aa6051241e365056d51280c872ca80403a16f SHA256 b7243481f566f290bae25c87e7f8532201f3b14731bbee1dae385ffd66e00e79
-DIST iodine-0.6.0-rc1.tar.gz 89827 RMD160 6974beac28e07b0c280d7095f15d13699e9cad65 SHA1 4fa9a248b8a84df8a727a5d749e669e58136edca SHA256 dacf950198b68fd1dae09fe980080155b0c75718f581c08e069eee0c1b6c5e60
-EBUILD iodine-0.6.0_rc1-r1.ebuild 1076 RMD160 ebddd55a888a6dcb777aca5f0bc3302a56f193c0 SHA1 92455ae5927861df14fb05d2776227e7aeb750c3 SHA256 5d2bc2efb86ed72bb740c792ed558dd1c8f6fb802a4d20a209ffb1ef86599c4f
-MISC ChangeLog 1076 RMD160 61bad65e7207512bace809ded10fb06dcf62d62d SHA1 64929702270020ba79c33b734c80651ffaf5b583 SHA256 e517170b8508523b62e9548c809f49cd903d329a31c74e3201dd090c096bd45f
-MISC metadata.xml 520 RMD160 297cd6f75315a31bd6d72e3bf959b0ff23155127 SHA1 cdfca2514299ecac7cf87fe497502244b241c641 SHA256 a565f5d7388a3a1d9f5e921f8fa1922b59a857eb3121a943a2838e696551312b
diff --git a/net-misc/iodine/files/iodine-0.5.2-Makefile.patch b/net-misc/iodine/files/iodine-0.5.2-Makefile.patch
deleted file mode 100644
index 10e2512..0000000
--- a/net-misc/iodine/files/iodine-0.5.2-Makefile.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff -NrU5 iodine-0.5.2.original/src/Makefile iodine-0.5.2/src/Makefile
---- iodine-0.5.2.original/src/Makefile 2009-08-07 19:58:30.000000000 -0600
-+++ iodine-0.5.2/src/Makefile 2009-08-07 20:34:01.000000000 -0600
-@@ -1,18 +1,18 @@
--CC = gcc
-+#CC = gcc
- COMMONOBJS = tun.o dns.o read.o encoding.o login.o base32.o base64.o md5.o common.o
- CLIENTOBJS = iodine.o
- CLIENT = ../bin/iodine
- SERVEROBJS = iodined.o user.o fw_query.o
- SERVER = ../bin/iodined
-
- OS = `echo $(TARGETOS) | tr "a-z" "A-Z"`
- ARCH = `uname -m`
-
- LIBPATH = -L.
--LDFLAGS = -lz `sh osflags $(TARGETOS) link` $(LIBPATH)
--CFLAGS = -c -g -Wall -D$(OS) -pedantic `sh osflags $(TARGETOS) cflags`
-+LDFLAGS += -lz `sh osflags $(TARGETOS) link` $(LIBPATH)
-+CFLAGS += -c -g -Wall -D$(OS) -pedantic `sh osflags $(TARGETOS) cflags`
-
- all: stateos $(CLIENT) $(SERVER)
-
- stateos:
- @echo OS is $(OS), arch is $(ARCH)
-@@ -27,11 +27,11 @@
- @mkdir -p ../bin
- @$(CC) $(COMMONOBJS) $(SERVEROBJS) -o $(SERVER) $(LDFLAGS)
-
- .c.o:
- @echo CC $<
-- @$(CC) $(CFLAGS) $< -o $@
-+ @$(CC) $(CFLAGS) $(LDFLAGS) $< -o $@
-
- clean:
- @echo "Cleaning src/"
- @rm -f $(CLIENT){,.exe} $(SERVER){,.exe} *~ *.o *.core
-
diff --git a/net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch b/net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch
deleted file mode 100644
index 529d242..0000000
--- a/net-misc/iodine/files/iodine-0.6.0_rc1-TestMessage.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff -NrU5 iodine-0.6.0-rc1.original/Makefile iodine-0.6.0-rc1/Makefile
---- iodine-0.6.0-rc1.original/Makefile 2009-01-25 15:40:04.000000000 -0600
-+++ iodine-0.6.0-rc1/Makefile 2011-06-07 14:09:00.000000000 -0600
-@@ -48,12 +48,11 @@
- $(RM) $(RM_FLAGS) $(DESTDIR)$(sbindir)/iodine
- $(RM) $(RM_FLAGS) $(DESTDIR)$(sbindir)/iodined
- $(RM) $(RM_FLAGS) $(DESTDIR)$(mandir)/man8/iodine.8
-
- test: all
-- @echo "!! The check library is required for compiling and running the tests"
-- @echo "!! Get it at http://check.sf.net"
-+ @echo "Executing tests target"
- @(cd tests; $(MAKE) TARGETOS=$(TARGETOS) all)
-
- clean:
- @echo "Cleaning..."
- @(cd src; $(MAKE) clean)
diff --git a/net-misc/iodine/files/iodine-0.6.0_rc1-ifconfig-path.patch b/net-misc/iodine/files/iodine-0.6.0_rc1-ifconfig-path.patch
deleted file mode 100644
index 074231f..0000000
--- a/net-misc/iodine/files/iodine-0.6.0_rc1-ifconfig-path.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ur iodine-0.6.0-rc1-original/src/tun.c iodine-0.6.0-rc1/src/tun.c
---- iodine-0.6.0-rc1-original/src/tun.c 2012-06-01 22:04:35.870962402 +0200
-+++ iodine-0.6.0-rc1/src/tun.c 2012-06-02 04:32:08.967846671 +0200
-@@ -455,7 +455,7 @@
- }
- #ifndef WINDOWS32
- snprintf(cmdline, sizeof(cmdline),
-- "/sbin/ifconfig %s %s %s netmask %s",
-+ "PATH=/bin:/sbin ifconfig %s %s %s netmask %s",
- if_name,
- ip,
- #ifdef FREEBSD
-@@ -522,7 +522,7 @@
-
- if (mtu > 200 && mtu <= 1500) {
- snprintf(cmdline, sizeof(cmdline),
-- "/sbin/ifconfig %s mtu %u",
-+ "PATH=/bin:/sbin ifconfig %s mtu %u",
- if_name,
- mtu);
-
diff --git a/net-misc/iodine/files/iodined.conf b/net-misc/iodine/files/iodined.conf
deleted file mode 100644
index 7889b08..0000000
--- a/net-misc/iodine/files/iodined.conf
+++ /dev/null
@@ -1,44 +0,0 @@
-# /etc/conf.d/iodined: config file for /etc/init.d/iodined
-
-# Drop privileges to this user after startup
-# This is used by the -u argument. Comment out to keep running as root.
-IODINED_USER="nobody"
-
-# Chroot to this directory after startup
-# This is used by the -t argument. Comment out to avoid chroot.
-IODINED_CHROOT="/var/empty"
-
-# This password needs to be used in all clients when they connect
-# This is used by the -P argument
-IODINED_PASSWD=""
-
-# This is the MTU (Max Transmit Unit) used in the tunnel.
-# You probably dont need this field at all, downstream data will
-# now be fragmented. This is used by the -m argument
-#IODINED_MTU=1020
-
-# The server port to listen on. You should normally not change this.
-# See man page. This is used by the -p argument
-#IODINED_LISTENPORT=53
-
-# The IP address to return as reply to NS queries. If not set, it will
-# be the destination address of the query. Used by the -n argument
-#IODINED_EXTERN_IP=1.1.1.1
-
-# The port used by a "real" DNS server on localhost. Queries for
-# domains not handled by iodined will be forwarded to this port,
-# and answers will be routed back. Used by the -b argument
-#IODINED_LOCAL_DNS_PORT=5353
-
-# The IP number to listen on.
-# This is used by the -l argument
-#IODINED_LISTENIP=127.0.0.1
-
-# This IP number will be used by the local tun device.
-IODINED_IP="172.28.0.1"
-
-# Use subdomains to this domain for network tunneling
-# If a real domain is used, it should be delegated to this server with
-# a NS entry in the domain zone (see man page)
-IODINED_DOMAIN="blah.abc"
-
diff --git a/net-misc/iodine/files/iodined.init b/net-misc/iodine/files/iodined.init
deleted file mode 100644
index c569ba0..0000000
--- a/net-misc/iodine/files/iodined.init
+++ /dev/null
@@ -1,62 +0,0 @@
-#!/sbin/runscript
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/files/iodined.init,v 1.1 2009/09/26 19:24:35 vostorga Exp $
-
-PID_FILE="/var/run/iodined.pid"
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting iodined"
- ARGS=""
- if [ "$IODINED_USER" ]; then
- ARGS="$ARGS -u $IODINED_USER"
- fi
- if [ "$IODINED_CHROOT" ]; then
- ARGS="$ARGS -t $IODINED_CHROOT"
- fi
- if [ "$IODINED_MTU" ]; then
- ARGS="$ARGS -m $IODINED_MTU"
- fi
- if [ "$IODINED_LISTENPORT" ]; then
- ARGS="$ARGS -p $IODINED_LISTENPORT"
- fi
- if [ "$IODINED_EXTERN_IP" ]; then
- ARGS="$ARGS -n $IODINED_EXTERN_IP"
- fi
- if [ "$IODINED_LOCAL_DNS_PORT" ]; then
- ARGS="$ARGS -b $IODINED_LOCAL_DNS_PORT"
- fi
- if [ "$IODINED_LISTENIP" ]; then
- ARGS="$ARGS -l $IODINED_LISTENIP"
- fi
- if [ "$IODINED_PASSWD" ]; then
- ARGS="$ARGS -P $IODINED_PASSWD"
- else
- eerror "Please set a password (IODINED_PASSWD) in /etc/conf.d/iodined!"
- return 1
- fi
- if [ "$IODINED_IP" ]; then
- ARGS="$ARGS $IODINED_IP"
- else
- eerror "Please set an IP (IODINED_IP) in /etc/conf.d/iodined!"
- return 1
- fi
- if [ "$IODINED_DOMAIN" ]; then
- ARGS="$ARGS $IODINED_DOMAIN"
- else
- eerror "Please set a domain (IODINED_DOMAIN) in /etc/conf.d/iodined!"
- return 1
- fi
- start-stop-daemon --start --exec /usr/bin/iodined --pidfile $PID_FILE -- -F $PID_FILE $ARGS
- eend $?
-}
-
-stop() {
- ebegin "Stopping iodined"
- start-stop-daemon --stop --exec /usr/bin/iodined --pidfile $PID_FILE
- eend $?
-}
diff --git a/net-misc/iodine/iodine-0.6.0_rc1-r1.ebuild b/net-misc/iodine/iodine-0.6.0_rc1-r1.ebuild
deleted file mode 100644
index 2e8fb64..0000000
--- a/net-misc/iodine/iodine-0.6.0_rc1-r1.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iodine/iodine-0.6.0_rc1.ebuild,v 1.3 2011/11/05 22:38:07 robbat2 Exp $
-
-inherit linux-info eutils
-
-MY_P="${P/_/-}"
-
-DESCRIPTION="IP over DNS tunnel"
-HOMEPAGE="http://code.kryo.se/iodine/"
-SRC_URI="http://code.kryo.se/${PN}/${MY_P}.tar.gz"
-
-CONFIG_CHECK="~TUN"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="sys-libs/zlib"
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack(){
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-ifconfig-path.patch
- epatch "${FILESDIR}"/${P}-TestMessage.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die "make failed"
-}
-
-src_install() {
- dobin bin/iodine bin/iodined || die "binaries failed"
- dodoc README CHANGELOG || die "docs failed"
- doman man/iodine.8 || die "man failed"
-
- newinitd "${FILESDIR}"/iodined.init iodined || die "initd failed"
- newconfd "${FILESDIR}"/iodined.conf iodined || die "confd failed"
- keepdir /var/empty
-}
diff --git a/net-misc/iodine/metadata.xml b/net-misc/iodine/metadata.xml
deleted file mode 100644
index 2e762b0..0000000
--- a/net-misc/iodine/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer>
- <email>vostorga@gentoo.org</email>
- <name>Víctor Ostorga</name>
- </maintainer>
- <maintainer>
- <email>root@kryo.se</email>
- <name>Erik Ekman</name>
- </maintainer>
- <longdescription>iodine lets you tunnel IPv4 data through a DNS server. This can be usable in different situations where internet access is firewalled, but DNS queries are allowed</longdescription>
-</pkgmetadata>