summaryrefslogtreecommitdiffstats
path: root/net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2013-02-10 20:12:23 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2013-02-10 20:12:23 +0100
commit99a170c0bd933be33f9e2b514205cf009a3a2bf6 (patch)
tree16fa7f7e0bd60c446cafe8dd7f5999558dc9a2e6 /net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild
parentI actually use this, apparantly. (diff)
downloadportage-99a170c0bd933be33f9e2b514205cf009a3a2bf6.tar.xz
portage-99a170c0bd933be33f9e2b514205cf009a3a2bf6.zip
Soulseek qt client.
Diffstat (limited to 'net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild')
-rw-r--r--net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild b/net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild
new file mode 100644
index 0000000..6facf9b
--- /dev/null
+++ b/net-p2p/soulseek-qt/soulseek-qt-20130112.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+DESCRIPTION="Official binary Qt SoulSeek client."
+HOMEPAGE="http://www.soulseekqt.net/"
+LICENSE="free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+BINARY_NAME="SoulseekQt-$((${PV:4:2}))-$((${PV:6:2}))-${PV:0:4}"
+BASE_URI="http://www.soulseekqt.net/SoulseekQT/Linux/${BINARY_NAME}"
+IUSE=""
+SRC_URI="
+ x86? ( ${BASE_URI}.tgz )
+ amd64? ( ${BASE_URI}-64bit.tgz )
+ "
+DEPEND=""
+RDEPEND="
+ x11-libs/qt-gui:4
+ x11-libs/qt-core:4
+ "
+RESTRICT="mirror"
+S="${WORKDIR}"
+src_install() {
+ exeinto /usr/bin
+ if use amd64; then
+ BINARY_NAME="${BINARY_NAME}-64bit"
+ fi
+ newexe "$BINARY_NAME" soulseek-qt
+}