summaryrefslogtreecommitdiffstats
path: root/net-wireless/gr-air-modes/gr-air-modes-9999.ebuild
diff options
context:
space:
mode:
authorJason A. Donenfeld <Jason@zx2c4.com>2015-02-10 21:47:34 +0100
committerJason A. Donenfeld <Jason@zx2c4.com>2015-02-10 21:47:34 +0100
commite521a42f7b4fdac936c6de00768c9aa8309df0f6 (patch)
tree5f75459be52ea93a041d2740b2a5573315321171 /net-wireless/gr-air-modes/gr-air-modes-9999.ebuild
parentAdd new gnu portable threads library. (diff)
downloadportage-e521a42f7b4fdac936c6de00768c9aa8309df0f6.tar.xz
portage-e521a42f7b4fdac936c6de00768c9aa8309df0f6.zip
Updates
Diffstat (limited to 'net-wireless/gr-air-modes/gr-air-modes-9999.ebuild')
-rw-r--r--net-wireless/gr-air-modes/gr-air-modes-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-wireless/gr-air-modes/gr-air-modes-9999.ebuild b/net-wireless/gr-air-modes/gr-air-modes-9999.ebuild
new file mode 100644
index 0000000..84270ae
--- /dev/null
+++ b/net-wireless/gr-air-modes/gr-air-modes-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+inherit python cmake-utils git-2
+
+DESCRIPTION="This module implements a complete Mode S and ADS-B receiver for Gnuradio"
+HOMEPAGE="https://www.cgran.org/wiki/gr-air-modes"
+
+EGIT_REPO_URI="https://github.com/bistromath/gr-air-modes.git"
+EGIT_BRANCH="master"
+
+KEYWORDS="~amd64"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="rtl fgfs +gui uhd"
+DEPEND=">=net-wireless/gnuradio-3.7.0:=
+ net-wireless/gr-osmosdr
+ dev-python/pyzmq
+ fgfs? ( sci-libs/scipy
+ games-simulation/flightgear )
+ rtl? ( net-wireless/rtl-sdr )
+ uhd? ( >=net-wireless/uhd-3.4.0 )
+ gui? ( dev-python/pyqwt )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Look-for-qwt-in-right-place.patch
+}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_compile() {
+ cmake-utils_src_compile -j1
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_convert_shebangs 2 "${ED}"usr/bin/*
+}